Problème relativement urgent bien qu'idiot [réglé]

De façon transitoire, ce forum reste ouvert le temps nécessaire pour les utilisateurs francophones de passer au forum multilingue.
User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Problème relativement urgent bien qu'idiot [réglé]

Postby amnesix » 26 Dec 2014 10:41

Bonjour, et désolé de réveiller le forum...

Je suis photographe, mais n'utilise que des logiciels libres. Parmi ceux-ci, un concurrent (sérieux) de Lightroom : Darktable.

J'ai maintenant *besoin* de la version 1.6.1. SolydX m'offre la 1.4.

Sur le site de Darktable, ils m'expliquent comment, à partir des fichier d'un PPA, fabriquer ce qu'ils appellent un «nice package» qui fonctionne sur debian :

Code: Select all

$ sudo apt-get install debhelper dpkg-dev fakeroot
$ sudo apt-get build-dep darktable
$ tar zxvf darktable_$VERSION.orig.tar.gz
$ cd darktable-$VERSION
$ tar zxvf ../darktable_$VERSION.debian.tar.gz
$ dpkg-buildpackage -rfakeroot
Dès la seconde ligne de commandes, j'ai un problème que je ne sais pas régler :

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: You must put some 'source' URIs in your sources.list
De quelles sources est-ce qu'on parle ?

Le PPA qui contient la version qui m'intéresse est :
https://launchpad.net/~pmjdebruijn/+arc ... le-release

Je croise les doigts... :)

Est-ce quelqu'un aurait une idée ? Cas sinon, je suis obligé de changer de crémerie pour passer sous Mint, et pour être honnête, j'ai pas envie.

User avatar
raivac
Posts: 121
Joined: 02 Sep 2013 22:25
Location: France, Lyon

Re: Problème relativement urgent bien qu'idiot

Postby raivac » 26 Dec 2014 19:58

Slt,

j'ai testé chez moi et c'est bien les adresses des dépots qu'il demande:

Code: Select all

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Vous devez insérer quelques adresses « sources » dans votre sources.list
peut-être les dépots indiqués ici (uniquement la partie 'source' et pas les binaires je pense):
https://launchpad.net/~pmjdebruijn/+arc ... le-release

Code: Select all

deb-src http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu trusty main 
Avant d'aller plus loin, je te conseille vivement (si tu as de la place sur tes disques) de le faire sous virtualbox.
Avec les instantanés, tu pourras tester et retester jusqu'à plus soif sans rien casser.

je t'avoue que je n'ai jamais tenté ce genre de truc...

Thierry
SolydX x32

jojo 35
Posts: 98
Joined: 12 Aug 2013 07:39
Location: Région de Rennes

Re: Problème relativement urgent bien qu'idiot

Postby jojo 35 » 27 Dec 2014 07:24

Bonjour Amnesix, ;)

Est-ce que la 1.6 te suffit ? Dans ce cas là, tu peux avoir les sources là : https://github.com/darktable-org/darkta ... 6.0.tar.xz
Joseph
Laptop ASUS R510LDV
IntelCore I5-4210U/BGA, up to 2,7 GHz
Optimus - Nvidia ge force 820M
- intel Corporation Haswel-ULT integrated Graphics Controllers
Ram DDR3L1600 2G+4G
HDD 1TB 2.5' 5400R SATA
SOLYDX (et win 8.1) 64 bits

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 26 Jan 2015 10:11

Hello amnesix,
J'arrive après la bataille, mais il est aussi possible d'installer la version 1.6.1 depuis le dépôt Debian expérimental (voir ici:
https://packages.debian.org/search?keyw ... lla-search)
Si tu ne sait pas comment activer le dépôt expérimental, je peux t'aider sans souci ici ;)
Tiens-nous au courant.
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 26 Jan 2015 10:24

Si tu ne sait pas comment activer le dépôt expérimental, je peux t'aider sans souci ici
Ah, quelqu'un lit dans mon esprit ! :D

Cela dit : je commence à m'inquiéter quant au futur de SolydX. Si tu me dis que ça va durer, alors d'accord : je prends très volontiers les paquets «expérimentaux» de Debian, dès que tu me l'auras expliqué. Mais le forum est mort depuis deux mois, on est fin janvier et toujours pas d'upgrade... je m'inquiète...

devrais-je ?

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 26 Jan 2015 13:32

Pour te rassurer en quelques mots: oui, SolydXK va durer ;)
[off]De façon plus complète, il est normal qu'il n'y ait pas d'update packs, car le système va changer...Je vais rapidement poster un message qui expliquera assez précisément ce qui est prévu par l'équipe.[off]

Pour ce qui est d'experimental, voici la marche à suivre (source: https://wiki.debian.org/fr/DebianExperimental)
  • ajouter la source des dépôts 'expérimental'
    On ouvre son terminal et on y tape:

    Code: Select all

    sudo nano /etc/apt/sources.list
    et on y rajoute la ligne suivante

    Code: Select all

      deb http://ftp.debian.org/debian experimental main
    on enregistre (control+O, entrée, control+X)
  • on met à jour les dépôts (pour y ajouter experimental)

    Code: Select all

    sudo apt-get update
  • on ajoute son programme favori :D

    Code: Select all

    sudo apt-get -t experimental install darktable_1.6.1-2
    ...
ou il y a plus facile encore :mrgreen: :
On va tout en bas de cette page là (https://packages.debian.org/experimental/darktable), on choisit le paquet en fonction de son architecture d'ordinateur (i386, amd64,...) on choisit le dépôt proche de chez soi, et on téléchagre et installe avec Gdebi.
PS: je n'ai pas testé sur mon ordi. Il y a un 'risque' qu'il y ait un souci de dépendances (car les paquets de ce dépôts sont calibrés pour fonctionner avec Debian Sid/unstable)...J'espère pour toi que non.
Si jamais c'est le cas, on regardera pour construire le paquet (si si, c'est facile tu verras, puisque tu as la notice).
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 26 Jan 2015 15:10

Ça marche pas. :(

Code: Select all

$ sudo apt-get -t experimental install darktable_1.6.1-2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package darktable_1.6.1-2
E: Couldn't find any package by regex 'darktable_1.6.1-2'
Ma sources.list :

Code: Select all

deb http://packages.solydxk.com/production/ solydxk main upstream import kdenext
deb http://ftp.nluug.nl/os/Linux/distr/solydxk/debian/production testing main contrib non-free
deb http://ftp.nluug.nl/os/Linux/distr/solydxk/debian/production/multimedia testing main non-free
deb http://debian.solydxk.com/security testing/updates main contrib non-free
deb http://community.solydxk.com/production/ solydxk main
deb http://ftp.debian.org/debian experimental main
J'ai bien fait l'update :

Code: Select all

$ sudo apt-get update
Hit http://ftp.nluug.nl testing InRelease
Hit http://ftp.debian.org experimental InRelease                               
Hit http://ftp.nluug.nl testing InRelease                                      
Hit http://ftp.nluug.nl testing/main amd64 Packages                            
Get:1 http://ftp.debian.org experimental/main amd64 Packages/DiffIndex [7,819 B]
Hit http://ftp.nluug.nl testing/contrib amd64 Packages                         
Hit http://ftp.nluug.nl testing/non-free amd64 Packages                        
Hit http://debian.solydxk.com testing/updates InRelease                        
Hit http://community.solydxk.com solydxk InRelease                             
Get:2 http://ftp.debian.org experimental/main i386 Packages/DiffIndex [7,819 B]
Hit http://packages.solydxk.com solydxk InRelease                              
Hit http://ftp.nluug.nl testing/main i386 Packages                             
Hit http://ftp.nluug.nl testing/contrib i386 Packages                          
Get:3 http://ftp.debian.org experimental/main Translation-en/DiffIndex [7,819 B]
Hit http://ftp.nluug.nl testing/non-free i386 Packages             
Hit http://debian.solydxk.com testing/updates/main amd64 Packages              
Hit http://community.solydxk.com solydxk/main amd64 Packages                   
Hit http://packages.solydxk.com solydxk/main amd64 Packages                    
Hit http://debian.solydxk.com testing/updates/contrib amd64 Packages           
Hit http://ftp.nluug.nl testing/main amd64 Packages                            
Hit http://ftp.nluug.nl testing/non-free amd64 Packages                        
Hit http://community.solydxk.com solydxk/main i386 Packages                    
Hit http://packages.solydxk.com solydxk/upstream amd64 Packages                
Hit http://ftp.nluug.nl testing/main i386 Packages                             
Hit http://debian.solydxk.com testing/updates/non-free amd64 Packages          
Hit http://ftp.nluug.nl testing/non-free i386 Packages                         
Hit http://packages.solydxk.com solydxk/import amd64 Packages                  
Hit http://debian.solydxk.com testing/updates/main i386 Packages               
Hit http://packages.solydxk.com solydxk/kdenext amd64 Packages                 
Hit http://debian.solydxk.com testing/updates/contrib i386 Packages            
Hit http://packages.solydxk.com solydxk/main i386 Packages                     
Hit http://debian.solydxk.com testing/updates/non-free i386 Packages           
Hit http://packages.solydxk.com solydxk/upstream i386 Packages                 
Hit http://packages.solydxk.com solydxk/import i386 Packages                   
Hit http://packages.solydxk.com solydxk/kdenext i386 Packages                  
Ign http://community.solydxk.com solydxk/main Translation-en_US                
Ign http://community.solydxk.com solydxk/main Translation-en                   
Ign http://ftp.nluug.nl testing/contrib Translation-en_US             
Ign http://ftp.nluug.nl testing/contrib Translation-en                
Ign http://ftp.nluug.nl testing/main Translation-en_US
Ign http://ftp.nluug.nl testing/main Translation-en                   
Ign http://ftp.nluug.nl testing/non-free Translation-en_US            
Ign http://ftp.nluug.nl testing/non-free Translation-en
Ign http://ftp.nluug.nl testing/main Translation-en_US
Ign http://ftp.nluug.nl testing/main Translation-en
Ign http://ftp.nluug.nl testing/non-free Translation-en_US
Ign http://ftp.nluug.nl testing/non-free Translation-en
Ign http://debian.solydxk.com testing/updates/contrib Translation-en_US        
Ign http://debian.solydxk.com testing/updates/contrib Translation-en           
Ign http://debian.solydxk.com testing/updates/main Translation-en_US           
Ign http://debian.solydxk.com testing/updates/main Translation-en              
Ign http://debian.solydxk.com testing/updates/non-free Translation-en_US       
Ign http://debian.solydxk.com testing/updates/non-free Translation-en          
Ign http://packages.solydxk.com solydxk/import Translation-en_US               
Ign http://packages.solydxk.com solydxk/import Translation-en                  
Ign http://packages.solydxk.com solydxk/kdenext Translation-en_US              
Ign http://packages.solydxk.com solydxk/kdenext Translation-en                 
Ign http://packages.solydxk.com solydxk/main Translation-en_US                 
Ign http://packages.solydxk.com solydxk/main Translation-en                    
Ign http://packages.solydxk.com solydxk/upstream Translation-en_US             
Ign http://packages.solydxk.com solydxk/upstream Translation-en                
Fetched 23.5 kB in 10s (2,333 B/s)                                             
Reading package lists... Done
Qu'est-ce que j'ai fait de travers ?

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 26 Jan 2015 17:52

amnesix wrote:Ça marche pas. :(

Code: Select all

$ sudo apt-get -t experimental install darktable_1.6.1-2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package darktable_1.6.1-2
E: Couldn't find any package by regex 'darktable_1.6.1-2'
Qu'est-ce que j'ai fait de travers ?
Hum...Je crois que je me suis trompé :roll:
Essaye

Code: Select all

sudo apt-get -t experimental install darktable
au lieu de

Code: Select all

 sudo apt-get -t experimental install darktable_1.6.1-2
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 26 Jan 2015 18:06

Toujours pas :

Code: Select all

Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 darktable : Depends: libcairo2 (>= 1.14.0) but 1.12.16-5 is to be installed
             Depends: libjpeg62-turbo (>= 1.3.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
:)

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 26 Jan 2015 18:30

Bon je m'étais bien trompé.... :D
On a un souci de dépendances non satisfaites...ce que je craignais.

Bon, on va y arriver, t'inquiètes pas.
Tu as essayé la methode de Thierry (Raivac) ou pas? (rajouter les sources)
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 26 Jan 2015 18:38

Tu as essayé la methode de Thierry (Raivac) ou pas? (rajouter les sources)
Depuis bébé, on m'a toujours dit que debian ne supporte pas les ppa...

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 26 Jan 2015 20:54

amnesix wrote:
Tu as essayé la methode de Thierry (Raivac) ou pas? (rajouter les sources)
Depuis bébé, on m'a toujours dit que debian ne supporte pas les ppa...
Oui, et c'est tout à fait vrai :ugeek:
Mais quand tu compiles (ie 'construis') un paquet pour un programme, il te faut certains fichiers sources en plus donc une ligne de ton source.list commence par deb-src
On peut aussi prendre les sources de Debian experimental, c'est mieux,non? :mrgreen:

Code: Select all

deb-src http://ftp.fr.debian.org/debian/ experimental main contrib non-free
à rajouter à ton source.list, puis

Code: Select all

sudo apt-get update
et ensuite, utilise le vademecum que le site de darktable t'a donné:

Code: Select all

sudo apt-get install debhelper dpkg-dev fakeroot
$ sudo apt-get build-dep darktable
$ tar zxvf darktable_$VERSION.orig.tar.gz
$ cd darktable-$VERSION
$ tar zxvf ../darktable_$VERSION.debian.tar.gz
$ dpkg-buildpackage -rfakeroot
Allez, on s'approche de la résolution!
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 27 Jan 2015 08:01

perdu ! :)

Code: Select all

sudo apt-get build-dep darktable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Can not find version '1.4.2-1' of package 'darktable'
E: Unable to find a source package for darktable
.... et d'ailleurs c'est 1.6 dont j'ai besoin... :)

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 27 Jan 2015 14:22

Arf...Ecoute je vais chercher de mon côté et je reviens vers toi ok?
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 27 Jan 2015 14:31

Écoute : j'ai maintenant une machine opérationnelle (Mint), donc je peux attendre. Je vais déjà attendre l'update de SolydX, peut-être que ce sera réglé là. Sinon, j'envisagerai, si besoin, ma trahison... :(

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Problème relativement urgent bien qu'idiot

Postby belze » 27 Jan 2015 23:18

pour moi il est possible avec testing repo activé at avec pinning

Code: Select all

LANG=C cat /etc/apt/sources.list
deb http://ftp.nluug.nl/os/Linux/distr/solydxk/packages/production solydxk main upstream import
deb http://ftp.nluug.nl/os/Linux/distr/solydxk/debian/production testing main contrib non-free
deb http://debian.solydxk.com/security testing/updates main contrib non-free
deb http://community.solydxk.com/production solydxk main
deb http://ftp.de.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://ftp.de.debian.org/debian unstable main contrib non-free
deb http://ftp.debian.org/debian experimental main

Code: Select all

LANG=C cat /etc/apt/apt.conf.d/81personale 
APT
{
        Default-Release "testing";
#        Cache-Limit 36000000;
        Get
        {
                AutomaticRemove "true";
                Fix-Broken "true";
                Purge "true";
                Show-Upgraded "true";
        }
}
Aptitude
{
        Autoclean-After-Update "true";
        Auto-Fix-Broken "true";
        Purge-Unused "true";
}
et voila

Code: Select all

LANG=C apt-get -t experimental install darktable -s
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  gtk2-engines libflickcurl0 libjs-prototype libjs-scriptaculous
The following NEW packages will be installed:
  darktable gtk2-engines libflickcurl0 libjs-prototype libjs-scriptaculous
0 upgraded, 5 newly installed, 0 to remove and 792 not upgraded.
Inst libflickcurl0 (1.25-3 SolydXK:1/testing, Debian:testing [amd64])
Inst gtk2-engines (1:2.20.2-3 SolydXK:1/testing, Debian:testing [amd64])
Inst libjs-prototype (1.7.1-3 SolydXK:1/testing, Debian:testing [all])
Inst libjs-scriptaculous (1.9.0-2 SolydXK:1/testing, Debian:testing [all])
Inst darktable (1.6.1-2 Debian:experimental [amd64])
Conf libflickcurl0 (1.25-3 SolydXK:1/testing, Debian:testing [amd64])
Conf gtk2-engines (1:2.20.2-3 SolydXK:1/testing, Debian:testing [amd64])
Conf libjs-prototype (1.7.1-3 SolydXK:1/testing, Debian:testing [all])
Conf libjs-scriptaculous (1.9.0-2 SolydXK:1/testing, Debian:testing [all])
Conf darktable (1.6.1-2 Debian:experimental [amd64])
-------
Image

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot

Postby ane champenois » 29 Jan 2015 10:00

Donc comme UP et alignement sur Jessie ce week-end, le souci est en passe d'être résolu :D
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot

Postby amnesix » 03 Feb 2015 19:24

Problème réglé ! Merci à tous ! :))

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: Problème relativement urgent bien qu'idiot [réglé]

Postby ane champenois » 03 Feb 2015 21:02

:geek: Félicitations!
Comment as-tu résolu au fait? (Pour info)
They did not know it was impossible so they did it.

User avatar
amnesix
Posts: 179
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: Problème relativement urgent bien qu'idiot [réglé]

Postby amnesix » 04 Feb 2015 03:56

En fait, j'en sais rien. :)

Après avoir fait l'upgrade 201501, je suis retourné sur la page que tu m'avais indiquée (https://wiki.debian.org/fr/DebianExperimental), et ça a marché. En fait j'ai l'impression d'avoir fait la même chose qu'avant.

J'imagine que j'avais fait quelque chose de faux avant l'upgrade, bien que je ne vois pas quoi. Cela dit, les ordinateurs n'ayant généralement aucune imagination, dans 99%, c'est l'utilisateur qui fait une bêtise, hein...

Mais bon : maintenant, ça marche. :D


Return to “Français (ATTENTION Archivage imminent)”

Who is online

Users browsing this forum: No registered users and 2 guests