UP - 30/11/2013 [TESTING][CLOSED]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby zerozero » 05 Dec 2013 16:18

the one-million-dollar question here is why this discrepancy when the only factor that changes is the date of the installation media.
libsmokebase3 might be one the reasons (and solving this one, solve the rest) but there's a few more lib in similar circumstances
bellow you see 2 instances of K-64 fully updated as of Dec 1st (when we first saw this issue)
- on the left an old installation; on the right a 201311 iso;
- on the left there's no upgradable packages (no little stars near the package)
- on the right we have those 12 upgradeable that as we all know by now don't upgrade)
snapshot168.png
- there's more versions mismatches
K64 old iso

Code: Select all

zerozero@k64-vb ~ $ dpkg -l libsmoke* | grep ^i
ii  libsmokebase3                          4:4.11.3-1                          amd64        SMOKE base library
ii  libsmokekdecore4-3                     4:4.10.5-1                          amd64        KDE Core SMOKE libraries
ii  libsmokekdeui4-3                       4:4.10.5-1                          amd64        KDE Ui SMOKE libraries
ii  libsmokekfile3                         4:4.10.5-1                          amd64        KFile SMOKE library
ii  libsmokekhtml3                         4:4.10.5-1                          amd64        KHTML SMOKE library
ii  libsmokekio3                           4:4.10.5-1                          amd64        KIO SMOKE library
ii  libsmokeknewstuff2-3                   4:4.10.5-1                          amd64        KNewStuff2 SMOKE library
ii  libsmokeknewstuff3-3                   4:4.10.5-1                          amd64        KNewStuff3 SMOKE library
ii  libsmokekparts3                        4:4.10.5-1                          amd64        KParts SMOKE libraries                                                            
ii  libsmokektexteditor3                   4:4.10.5-1                          amd64        KTextEditor SMOKE libraries                                                       
ii  libsmokekutils3                        4:4.10.5-1                          amd64        KUtils SMOKE libraries                                                            
ii  libsmokenepomuk3                       4:4.10.5-1                          amd64        Nepomuk SMOKE libraries                                                           
ii  libsmokeqtcore4-3                      4:4.11.3-1                          amd64        Qt Core SMOKE library
ii  libsmokeqtdbus4-3                      4:4.11.3-1                          amd64        Qt D-Bus SMOKE library
ii  libsmokeqtgui4-3                       4:4.11.3-1                          amd64        Qt Gui SMOKE library
ii  libsmokeqtnetwork4-3                   4:4.11.3-1                          amd64        Qt Network SMOKE library
ii  libsmokeqtopengl4-3                    4:4.11.3-1                          amd64        Qt OpenGL SMOKE library
ii  libsmokeqtsql4-3                       4:4.11.3-1                          amd64        Qt Sql SMOKE library
ii  libsmokeqtsvg4-3                       4:4.11.3-1                          amd64        Qt Svg SMOKE library
ii  libsmokeqtwebkit4-3                    4:4.11.3-1                          amd64        Qt WebKit SMOKE library
ii  libsmokeqtxml4-3                       4:4.11.3-1                          amd64        Qt Xml SMOKE library
ii  libsmokesolid3                         4:4.10.5-1                          amd64        Solid SMOKE libraries
K64 recent iso

Code: Select all

zerozero@k64 ~ $ dpkg -l libsmoke* | grep ^i
ii  libsmokebase3                          4:4.10.5-1~pre1+b4                  amd64        SMOKE base library
ii  libsmokekdecore4-3                     4:4.10.5-1                          amd64        KDE Core SMOKE libraries
ii  libsmokekdeui4-3                       4:4.10.5-1                          amd64        KDE Ui SMOKE libraries
ii  libsmokekfile3                         4:4.10.5-1                          amd64        KFile SMOKE library
ii  libsmokekhtml3                         4:4.10.5-1                          amd64        KHTML SMOKE library
ii  libsmokekio3                           4:4.10.5-1                          amd64        KIO SMOKE library
ii  libsmokeknewstuff2-3                   4:4.10.5-1                          amd64        KNewStuff2 SMOKE library
ii  libsmokeknewstuff3-3                   4:4.10.5-1                          amd64        KNewStuff3 SMOKE library
ii  libsmokekparts3                        4:4.10.5-1                          amd64        KParts SMOKE libraries
ii  libsmokektexteditor3                   4:4.10.5-1                          amd64        KTextEditor SMOKE libraries
ii  libsmokekutils3                        4:4.10.5-1                          amd64        KUtils SMOKE libraries
ii  libsmokenepomuk3                       4:4.10.5-1                          amd64        Nepomuk SMOKE libraries
ii  libsmokeqtcore4-3                      4:4.10.5-2                          amd64        Qt Core SMOKE library
ii  libsmokeqtdbus4-3                      4:4.10.5-2                          amd64        Qt D-Bus SMOKE library
ii  libsmokeqtgui4-3                       4:4.10.5-2                          amd64        Qt Gui SMOKE library
ii  libsmokeqtnetwork4-3                   4:4.10.5-2                          amd64        Qt Network SMOKE library
ii  libsmokeqtopengl4-3                    4:4.10.5-2                          amd64        Qt OpenGL SMOKE library
ii  libsmokeqtsql4-3                       4:4.10.5-2                          amd64        Qt Sql SMOKE library
ii  libsmokeqtsvg4-3                       4:4.10.5-2                          amd64        Qt Svg SMOKE library                                                                                        
ii  libsmokeqtwebkit4-3                    4:4.10.5-2                          amd64        Qt WebKit SMOKE library                                                                                     
ii  libsmokeqtxml4-3                       4:4.10.5-2                          amd64        Qt Xml SMOKE library                                                                                        
ii  libsmokesolid3                         4:4.10.5-1                          amd64        Solid SMOKE libraries                                                                                     
bliss of ignorance

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 30/11/2013 [TESTING]

Postby stelios » 05 Dec 2013 17:48

I changed the sources of my really old SolydK installation to testing (it was installed last December as Unof.LMDE KDE). The last UP applied was the one in November. I did not apply the new upgrades for this installation.

Here is what Synaptic tells me.
sldkDec-Synaptic.png
sldkDec-Synaptic.png (115.58 KiB) Viewed 2708 times
The packages marked as upgradeable, will not upgrade.

Code: Select all

dpkg -l libsmoke* | grep ^i
dpkg-query: no packages found matching libsmokebase3_4.10.5-1~pre1+b4_amd64.deb
dpkg-query: no packages found matching libsmokebase3_4.11.3-1_amd64.deb
and
smoke.png
smoke.png (38 KiB) Viewed 2942 times

Code: Select all

Package: *
Pin: release o=solydxk
Pin-Priority: 700

Package: *
Pin: origin packages.solydxk.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500

User avatar
Arjen Balfoort
Site Admin
Posts: 9423
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby Arjen Balfoort » 05 Dec 2013 18:02

The question is: do we need a preferences file at all?
I never fully understood this file, but perhaps Santa can shed a light on this (he'll be here as soon as he can).


SolydXK needs you!
Development | Testing | Translations

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 18:15

Schoelje wrote:The question is: do we need a preferences file at all?
I never fully understood this file, but perhaps Santa can shed a light on this (he'll be here as soon as he can).
Is there any reason we need to "prefer" SolydXK over Debian if there are no Debian repos in our standard sources.list?

(My limited knowledge being what it is... I've read a few tutorials and how-tos on preferences and pinning, but that does not an expert make.)

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 30/11/2013 [TESTING]

Postby stelios » 05 Dec 2013 18:16

Schoelje wrote:The question is: do we need a preferences file at all?
I never fully understood this file, but perhaps Santa can shed a light on this (he'll be here as soon as he can).
Are there files in kdenext that take precedence and their version should remain at an older state than those in testing if needed?
Right now, kdenext has a higher pin priority (700) than Debian (500).

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 18:20

Ahhhh. Yes. Kdenext....

User avatar
Arjen Balfoort
Site Admin
Posts: 9423
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby Arjen Balfoort » 05 Dec 2013 18:22

fleabus wrote:
Schoelje wrote:The question is: do we need a preferences file at all?
I never fully understood this file, but perhaps Santa can shed a light on this (he'll be here as soon as he can).
Is there any reason we need to "prefer" SolydXK over Debian if there are no Debian repos in our standard sources.list?

(My limited knowledge being what it is... I've read a few tutorials and how-tos on preferences and pinning, but that does not an expert make.)
We sometimes have debian packages in our own packages repository, but they are usually from sid or experimental because the ones in testing are broken, or missing. They always have a higher version number, which wouldn't pose a problem with a missing preferences file...I think :?


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9423
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby Arjen Balfoort » 05 Dec 2013 18:23

stelios wrote:
Schoelje wrote:The question is: do we need a preferences file at all?
I never fully understood this file, but perhaps Santa can shed a light on this (he'll be here as soon as he can).
Are there files in kdenext that take precedence and their version should remain at an older state than those in testing if needed?
Right now, kdenext has a higher pin priority (700) than Debian (500).
No, not at the moment, but again, only Santa could say something about that.


SolydXK needs you!
Development | Testing | Translations

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 18:29

Schoelje wrote: We sometimes have debian packages in our own packages repository, but they are usually from sid or experimental because the ones in testing are broken, or missing. They always have a higher version number, which wouldn't pose a problem with a missing preferences file...I think :?
When I get home I'll go ahead and re-run it without the Prefs file and see how it goes. I was just doing -s dry runs to test before. I was doing it on a separate partition anyway, and had them both backed up. should be interesting.

User avatar
Arjen Balfoort
Site Admin
Posts: 9423
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby Arjen Balfoort » 05 Dec 2013 18:43

This looks a lot better...at first glance:

Code: Select all

solydxk solydxk # mv /etc/apt/preferences /etc/apt/preferences.bak

solydxk solydxk # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libnepomukcleaner4 libtag1-rusxmms libtaskmanager4abi50
The following NEW packages will be installed:
  attr kde-base-artwork libasn1-8-heimdal libbasicusageenvironment0
  libboost-filesystem1.54.0 libboost-regex1.54.0 libboost-signals1.54.0
  libboost-thread1.54.0 libchromaprint0 libepub0 libfftw3-long3 libgme0
  libgroupsock1 libgssapi3-heimdal libhcrypto4-heimdal libhdb9-heimdal
  libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal
  libimobiledevice4 libkdc2-heimdal libkdecorations4abi2 libkrb5-26-heimdal
  libkwineffects1abi5 libkwinglutils1abi2 libldb1 liblivemedia16
  libplasmaclock4abi4 libproxy1 libquazip0 libroken18-heimdal libtag1-vanilla
  libtaskmanager4abi4 libusageenvironment1 libusbmuxd2 libvlccore7
  libwind0-heimdal libx264-140 libzip2 linux-headers-3.11-2-amd64
  linux-headers-3.11-2-common linux-image-3.11-2-amd64 linux-kbuild-3.11
  python-dnspython python-ldb python-samba python-talloc python-tdb
  samba-dsdb-modules samba-libs tdb-tools
The following packages will be upgraded:
  akonadi-backend-sqlite akonadi-server amarok amarok-common amarok-utils ark
  at-spi2-core bash-completion binfmt-support busybox console-tools cpp-4.6
  cpp-4.7 dbus dbus-x11 debconf debconf-i18n digikam digikam-private-libs
  dnsmasq-base dolphin evolution-data-server-common ffmpeg firefox
  firefox-l10n-en-us fonts-arphic-uming fonts-opensymbol freerdp-x11
  freespacenotifier g++-4.6 g++-4.7 gcc-4.6 gcc-4.6-base gcc-4.7 gcc-4.7-base
  gcc-4.7-base:i386 geoip-database gir1.2-pango-1.0 glib-networking
  glib-networking-services grep gsettings-desktop-schemas
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-x
  gtk2-engines-oxygen gtk2-engines-pixbuf gvfs gvfs-daemons gvfs-libs gwenview
  hostname hugin hugin-data hugin-tools ifupdown init-system-helpers
  initramfs-tools installation-report iso-codes kaddressbook kamera kate
  kate-data katepart kcalc kcharselect kde-baseapps-bin kde-baseapps-data
  kde-config-touchpad kde-runtime kde-runtime-data kde-style-oxygen
  kde-wallpapers-default kde-window-manager kde-workspace kde-workspace-bin
  kde-workspace-data kde-workspace-kgreet-plugins kdebase-runtime kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdenetwork-filesharing kdepasswd
  kdepim-runtime kdepimlibs-kio-plugins kdf kdm kdoctools kfind kget kgpg
  khelpcenter4 kinfocenter kio-audiocd kio-mtp kipi-plugins klibc-utils
  klipper kmenuedit kmix knotes konqueror-nsplugins konsole kopete kppp krdc
  ksaneplugin kscreensaver kscreensaver-xsavers ksnapshot ksysguard ksysguardd
  ksystemlog ktorrent kwalletmanager kwrite libakonadi-calendar4
  libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4
  libakonadi-kmime4 libakonadiprotocolinternals1 libatspi2.0-0 libavcodec54
  libavdevice54 libavfilter3 libavformat54 libavutil52 libbonobo2-0
  libbonobo2-common libboost-date-time1.49.0 libboost-date-time1.54.0
  libboost-filesystem1.49.0 libboost-filesystem1.53.0 libboost-iostreams1.54.0
  libboost-program-options1.54.0 libboost-python1.49.0 libboost-python1.54.0
  libboost-regex1.53.0 libboost-signals1.53.0 libboost-system1.49.0
  libboost-system1.53.0 libboost-system1.54.0 libboost-thread1.53.0 libcddb2
  libcdio-cdda1 libcdio-paranoia1 libcdio13 libconsole libdbus-1-3
  libdbus-1-3:i386 libdlrestrictions1 libdrm-dev libdrm-intel1
  libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1
  libdrm-radeon1:i386 libdrm2 libdrm2:i386 libdvbpsi9 libelf1 libelf1:i386
  libept1.4.12 libexttextcat-2.0-0 libexttextcat-data libfftw3-3
  libfftw3-double3 libfftw3-single3 libfreerdp-plugins-standard libfreerdp1
  libgadu3 libgail18 libgcc-4.7-dev libgeoip1 libgnome2-perl libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgpgme++2 libgphoto2-2
  libgphoto2-port0 libgpod-common libgpod4 libgssdp-1.0-3
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libgupnp-1.0-4 libhsqldb-java libhtml-format-perl
  libhunspell-1.3-0 libicu48 libidl0 libio-socket-inet6-perl libiso9660-8
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libkabc4
  libkactivities-bin libkactivities-models1 libkactivities6 libkateinterfaces4
  libkatepartinterfaces4 libkcal4 libkcalcore4 libkcalutils4 libkcddb4
  libkcmutils4 libkcompactdisc4 libkdcraw-data libkdcraw22 libkde3support4
  libkdeclarative5 libkdecore5 libkdepim4 libkdesu5 libkdeui5 libkdewebkit5
  libkdnssd4 libkemoticons4 libkephal4abi1 libkexiv2-11 libkexiv2-data
  libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4
  libkio5 libkipi-data libkipi11 libkjsapi4 libkjsembed4 libkldap4 libkleo4
  libklibc libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates libkonq5abi1
  libkontactinterface4 libkopete4 libkparts4 libkpimidentities4
  libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkqoauth0
  libkresources4 libkrosscore4 libksane-data libksane0 libkscreensaver5
  libksgrd4 libksignalplotter4 libktexteditor4 libktorrent-l10n libktorrent5
  libkunitconversion4 libkutils4 libkworkspace4abi2 libkxmlrpcclient4
  libllvm3.3 libllvm3.3:i386 libloudmouth1-0 libmailtransport4
  libmarblewidget16 libmicroblog4 libnepomuk4 libnepomukcore4
  libnepomukquery4a libnepomukutils4 libnepomukwidgets4abi1 libnspr4
  libnspr4-0d libnss-winbind libnss3 libnss3-1d libokularcore3 libopenconnect2
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4 libp11-kit0
  libp11-kit0:i386 libpam-winbind libpango-1.0-0 libpango1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libphonon4
  libpkcs11-helper1 libplasma-geolocation-interface4 libplasma3
  libplasmagenericshell4 libpoppler-glib8 libpoppler-qt4-4 libpoppler43
  libpopt0 libpostproc52 libprocesscore4abi1 libprocessui4a libqgpgme1
  libqtruby4shared2 libqtwebkit4 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-kde libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-writer librsvg2-2 librsvg2-common
  libsdl1.2debian libselinux1 libsemanage-common libsemanage1 libsepol1
  libsmbclient libsmokebase3 libsmokeqtcore4-3 libsmokeqtdbus4-3
  libsmokeqtgui4-3 libsmokeqtnetwork4-3 libsmokeqtopengl4-3 libsmokeqtsql4-3
  libsmokeqtsvg4-3 libsmokeqtwebkit4-3 libsmokeqtxml4-3 libsolid4 libsoprano4
  libspeex1 libspeexdsp1 libspice-server1 libsqlite3-0 libssl1.0.0
  libssl1.0.0:i386 libstdc++6-4.6-dev libstdc++6-4.7-dev libswresample0
  libswscale2 libsyndication4 libtag1c2a libtelepathy-qt4-2 libthai-data
  libthai0 libthreadweaver4 libuniconf4.6 libupower-glib1 libva-x11-1 libva1
  libvirtodbc0 libvlc5 libwavpack1 libwbclient0 libweather-ion6
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libwpg-0.2-2 libwvstreams4.6-base
  libwvstreams4.6-extras libxcb-composite0 libxcb-damage0 libxcb-dri2-0
  libxcb-dri2-0:i386 libxcb-dri2-0-dev libxcb-glx0 libxcb-glx0:i386
  libxcb-glx0-dev libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0
  libxcb-sync0 libxcb-xfixes0 libxcb-xtest0 libxcb-xv0 libxcb1 libxcb1:i386
  libxcb1-dev linux-headers-amd64 linux-image-amd64 linux-libc-dev make
  marble-data marble-plugins mplayer mplayerthumbs nepomuk-core-data
  nepomuk-core-runtime nvidia-detect okular openssh-client openssl
  oxygen-icon-theme p11-kit patch patchutils phonon phonon-backend-gstreamer
  phonon-backend-vlc plasma-dataengines-addons plasma-dataengines-workspace
  plasma-desktop plasma-netbook plasma-scriptengine-javascript
  plasma-scriptengine-python plasma-scriptengine-superkaramba
  plasma-widget-folderview plasma-widgets-addons plasma-widgets-workspace
  plymouth-themes-solydk pm-utils poppler-utils print-manager
  printer-driver-escpr printer-driver-min12xxw printer-driver-pnm2ppa
  python-cups python-cupshelpers python-kde4 python-nevow python-opencv
  python-qt4 python-qt4-dbus python-sip python-twisted-bin python-twisted-core
  python-twisted-web python-uno python3-pykde4 python3-pyqt4 python3-sip
  quassel-data-kde4 quassel-kde4 rsync ruby-locale ruby-qt4 ruby-qt4-webkit
  samba samba-common samba-common-bin smbclient solydxk-flashplugin-11
  solydxk-softwaremanager soprano-daemon speex steam:i386
  system-config-printer-udev systemsettings thunderbird thunderbird-l10n-en-us
  uno-libs3 upower ure usbmuxd user-setup virtuoso-opensource-6.1-bin
  virtuoso-opensource-6.1-common vlc vlc-data vlc-nox vlc-plugin-notify
  vlc-plugin-pulse wavpack wget winbind xserver-xorg-input-wacom
  xserver-xorg-video-nouveau
505 upgraded, 51 newly installed, 3 to remove and 0 not upgraded.
Need to get 570 MB of archives.
After this operation, 108 MB of additional disk space will be used.
Do you want to continue? [Y/n] 


SolydXK needs you!
Development | Testing | Translations

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 18:50

that's pretty much what I got. not exactly the same of course, but there was nothing held back. it was that restored installation that had the Lancelot and Nvidia :lol: 3.19.60. and nothing else, and it was a dry run.

when I get home I'll just go ahead and run the thing for real I can always restore it.

don't know why I didn't just do that this morning....

User avatar
Arjen Balfoort
Site Admin
Posts: 9423
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby Arjen Balfoort » 05 Dec 2013 19:28

Santa is fixing this, and I'll have to synchronize the repository when he's done.
Today is a special holiday: Sinterklaas, and I won't be at the PC all the time. I'll post back when I'm done.


SolydXK needs you!
Development | Testing | Translations

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 19:44

Have a good time Schoelje! :D

User avatar
timber
Posts: 539
Joined: 11 Aug 2013 21:01
Location: Pacific Northwest

Re: UP - 30/11/2013 [TESTING]

Postby timber » 05 Dec 2013 20:10

Santa wrote:Hi,

I just wanted to say that I hope KDE SC 4.11.4 will be ready soon.
Hi Santa, just wanted to send you a Thank You note.
Your work is greatly appreciated ...
... and an early Merry Christmas to you and yours!

Dave
timber

Samsung R580-M430 @ 2.27GHz - 8 GB RAM
Geforce 310M w/ nvidia-driver
SolydX/SolydM - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydK - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydKBE - Kernel 3.2.0-4-amd64 - LTS Update Pack: 2014.07.15

User avatar
kobros
Posts: 194
Joined: 28 Nov 2013 14:48
Location: Netherlands

Re: UP - 30/11/2013 [TESTING]

Postby kobros » 05 Dec 2013 21:38

Schoelje wrote:The question is: do we need a preferences file at all?
I never fully understood this file, but perhaps Santa can shed a light on this (he'll be here as soon as he can).
I've always used a preferences file in all of the debian/debian based distros that I used. Ever since 2002. If one wants or needs to use packages from another repository -one beyond the repos that come with the distro at hand- then one will probably need such a preferences file. Since most 100% debian based distros do rely heavily on debian repos they cannot afford to remove the preferences file. And why should they? Why should they recompile packages from source that are already available -and useable- in the proper debian repos? (Only valid for 100% debian compatible distros - not for the ones with *buntu in their name.....). All this compiling seems to me to be rather a waste of time . Except: SolydXK can't rely on Debian repos because it also uses testing, sid and experimental stuff for its own packaging.
Right?

And here we come (imho) to the crux of the matter: if SolydXK does provide -in its own repos- all that is wanted/needed by its customers then one doesn't need a preference file (or more exact: no pinning rules).
I believe this does place a rather heavy burden, not only on developing/compiling capability, but also on having -and maintaining- a good grasp on what it is that people want at any given time. To me this seems nearly impossible for a very small crew.

I have seen something like this happen with Mepis (which I used for 10 years - in fact I still do). Mepis 12 is 100% debian compatible with Debian Wheezy (stable). But Mepis now has a number of packaging people that will compile newer testing and sid applications - using the Mepis 12 development toolkit (and debian packaging rules) to make those apps available - after testing of course.
So the renewal is basically a constant process. Mepis apps are quite uptodate mostly. The maker of Mepis couldn't possibly do all of this by himself. He's a genius, but he's a one-man band.

It seems to me that this renewal process in SolydXK is cramped tightly into a few weeks - every month. Every month apps in several 'renewed' iso's need bug-squashing/confirmation/approval. I believe this approach is very commendable as a high level concept, but I think it will fail once the bugs cannot be squash quickly enough, within those allotted 1-2 weeks. Or if mistakes are made in patches or in compiling many, many packages for the SolydXK .iso's and repos.

I may be wrong here.
If so, then please blame it on my ignorance about SolydK.
Please don't feel offended or being attacked.
I'm only giving my honest opinion about what I've seen and noticed -- after less than a week of using SolydK64.



Could it be that the 64bit libsmokebase3_4.10.5-1~pre1+b4 package isn't OK? Would replacing that one with the non-offending libsmokebase3_4.11.3-1 package in a newer 'to be revised' .iso solve this issue?
Linux User #312596.
Mepis/Debian/antiX/MX/Win7

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 22:13

kobros wrote:And here we come (imho) to the crux of the matter: if SolydXK does provide -in its own repos- all that is wanted/needed by its customers then one doesn't need a preference file (or more exact: no pinning rules).
---------------------------
Could it be that the 64bit libsmokebase3_4.10.5-1~pre1+b4 package isn't OK? Would replacing that one with the non-offending libsmokebase3_4.11.3-1 package in a newer 'to be revised' .iso solve this issue?
It all makes sense to me, but I have very little experience with Linux, so I'm not sure I can provide any real relevant input. At my current level of experience I can provide [guided] assistance with testing for now. My efforts are purely experimental at this stage of the game. Gettin' better as I go, but it's a slow process... :)

As for the rest of it, Well said. You make many significant points.

You've probably seen this discussion, on the subject of communicating a late update, which turned into a discussion about the update interval.

-- Dave

User avatar
kobros
Posts: 194
Joined: 28 Nov 2013 14:48
Location: Netherlands

Re: UP - 30/11/2013 [TESTING]

Postby kobros » 05 Dec 2013 22:20

No, I hadn't seen that discussion (yet).....:-)
Thanks - but I'll read it now...

I did read that discussion. Thanks again.
I can really relate to the pressures such a frequent Update Cycle brings along in terms of time-planning of necessary events, communnicating with parties/persons involved, actually doing them, testing, bug-fixing, releasing and communicating. And all that within a very short, tight time-span.

Hat off to the team....:-)
Linux User #312596.
Mepis/Debian/antiX/MX/Win7

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 05 Dec 2013 23:00

Re-ran the test UP, this time without preferences, for the sake of the curiousity that killed the cat.

The upgrade ran without issue of any kind. Nothing was kept back. Afterwards it wasn't necessary to do any post-UP [nvidia] stuff. It booted up and ran just fine. So far... :D

I'm sure the prefs file is there for a very good reason --
Schoelje wrote:We sometimes have debian packages in our own packages repository, but ... They always have a higher version number, which wouldn't pose a problem with a missing preferences file...I think :?
So... if I continue without prefs, the system will sooner or later begin to act up...?
Don't know. Hope not. Anyway, interesting experiment.
So I'm going to keep using this partition, and let's see what happens.

Anyhoo:

Again, returned the partition to (almost) pristine state from backup. That is:

New K64 install, from 2013-11-25 iso, no plymouth. With Lancelot, Ubuntu fonts, and Nvidia 319.60. Various post-install config: Set up monitor, power management, check keyboard numlock & anti-aliasing settings, set auto-login, turn off splash, turn off audio feedback (system dings-and-bongs), turn off taskbar launch feedback, configure terminals, Firefox, and Back the Darn Thing Up! :D

Code: Select all

dv7-1270us fleabus # mv /etc/apt/preferences /etc/apt/prefs.backup
dv7-1270us fleabus # apt-get update
<snip>
dv7-1270us fleabus # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done

The following packages will be REMOVED:
  libnepomukcleaner4 libtag1-rusxmms libtaskmanager4abi50

The following NEW packages will be installed:
  attr kde-base-artwork libasn1-8-heimdal libbasicusageenvironment0 libboost-filesystem1.54.0 libboost-regex1.54.0
  libboost-signals1.54.0 libboost-thread1.54.0 libchromaprint0 libepub0 libfftw3-long3 libgme0 libgroupsock1 libgssapi3-heimdal
  libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libimobiledevice4
  libkdc2-heimdal libkdecorations4abi2 libkrb5-26-heimdal libkwineffects1abi5 libkwinglutils1abi2 libldb1 liblivemedia16
  libnvidia-ml1 libplasmaclock4abi4 libproxy1 libquazip0 libroken18-heimdal libtag1-vanilla libtaskmanager4abi4
  libusageenvironment1 libusbmuxd2 libvlccore7 libwind0-heimdal libx264-140 libzip2 linux-headers-3.11-2-amd64
  linux-headers-3.11-2-common linux-image-3.11-2-amd64 linux-kbuild-3.11 python-dnspython python-ldb python-samba python-talloc
  python-tdb samba-dsdb-modules samba-libs tdb-tools

The following packages will be upgraded:
  akonadi-backend-sqlite akonadi-server amarok amarok-common amarok-utils ark at-spi2-core bash-completion binfmt-support busybox
  console-tools cpp-4.6 cpp-4.7 dbus dbus-x11 debconf debconf-i18n digikam digikam-private-libs dnsmasq-base dolphin
  evolution-data-server-common ffmpeg firefox firefox-l10n-en-us fonts-arphic-uming fonts-opensymbol freerdp-x11 freespacenotifier
  g++-4.6 g++-4.7 gcc-4.6 gcc-4.6-base gcc-4.7 gcc-4.7-base gcc-4.7-base:i386 geoip-database gir1.2-pango-1.0 glib-networking
  glib-networking-services grep gsettings-desktop-schemas gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-x
  gtk2-engines-oxygen gtk2-engines-pixbuf gvfs gvfs-daemons gvfs-libs gwenview hostname hugin hugin-data hugin-tools ifupdown
  init-system-helpers initramfs-tools installation-report iso-codes kaddressbook kamera kate kate-data katepart kcalc kcharselect
  kde-baseapps-bin kde-baseapps-data kde-config-touchpad kde-runtime kde-runtime-data kde-style-oxygen kde-wallpapers-default
  kde-window-manager kde-workspace kde-workspace-bin kde-workspace-data kde-workspace-kgreet-plugins kdebase-runtime kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdenetwork-filesharing kdepasswd kdepim-runtime kdepimlibs-kio-plugins kdf kdm kdoctools kfind
  kget kgpg khelpcenter4 kinfocenter kio-audiocd kio-mtp kipi-plugins klibc-utils klipper kmenuedit kmix knotes
  konqueror-nsplugins konsole kopete kppp krdc ksaneplugin kscreensaver kscreensaver-xsavers ksnapshot ksysguard ksysguardd
  ksystemlog ktorrent kwalletmanager kwrite libakonadi-calendar4 libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4
  libakonadi-kde4 libakonadi-kmime4 libakonadiprotocolinternals1 libatspi2.0-0 libavcodec54 libavdevice54 libavfilter3
  libavformat54 libavutil52 libbonobo2-0 libbonobo2-common libboost-date-time1.49.0 libboost-date-time1.54.0
  libboost-filesystem1.49.0 libboost-filesystem1.53.0 libboost-iostreams1.54.0 libboost-program-options1.54.0
  libboost-python1.49.0 libboost-python1.54.0 libboost-regex1.53.0 libboost-signals1.53.0 libboost-system1.49.0
  libboost-system1.53.0 libboost-system1.54.0 libboost-thread1.53.0 libcddb2 libcdio-cdda1 libcdio-paranoia1 libcdio13 libconsole
  libdbus-1-3 libdbus-1-3:i386 libdlrestrictions1 libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386
  libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libdvbpsi9 libelf1 libelf1:i386 libept1.4.12 libexttextcat-2.0-0
  libexttextcat-data libfftw3-3 libfftw3-double3 libfftw3-single3 libfreerdp-plugins-standard libfreerdp1 libgadu3 libgail18
  libgcc-4.7-dev libgeoip1 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgl1-nvidia-glx-i386:i386 libgnome2-perl libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgpgme++2 libgphoto2-2 libgphoto2-port0 libgpod-common libgpod4 libgssdp-1.0-3
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgupnp-1.0-4 libhsqldb-java
  libhtml-format-perl libhunspell-1.3-0 libicu48 libidl0 libio-socket-inet6-perl libiso9660-8 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libkabc4 libkactivities-bin libkactivities-models1 libkactivities6 libkateinterfaces4
  libkatepartinterfaces4 libkcal4 libkcalcore4 libkcalutils4 libkcddb4 libkcmutils4 libkcompactdisc4 libkdcraw-data libkdcraw22
  libkde3support4 libkdeclarative5 libkdecore5 libkdepim4 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4
  libkephal4abi1 libkexiv2-11 libkexiv2-data libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4 libkio5
  libkipi-data libkipi11 libkjsapi4 libkjsembed4 libkldap4 libkleo4 libklibc libkmediaplayer4 libkmime4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates libkonq5abi1 libkontactinterface4 libkopete4
  libkparts4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkqoauth0 libkresources4 libkrosscore4
  libksane-data libksane0 libkscreensaver5 libksgrd4 libksignalplotter4 libktexteditor4 libktorrent-l10n libktorrent5
  libkunitconversion4 libkutils4 libkworkspace4abi2 libkxmlrpcclient4 libllvm3.3 libllvm3.3:i386 libloudmouth1-0 libmailtransport4
  libmarblewidget16 libmicroblog4 libnepomuk4 libnepomukcore4 libnepomukquery4a libnepomukutils4 libnepomukwidgets4abi1 libnspr4
  libnspr4-0d libnss-winbind libnss3 libnss3-1d libokularcore3 libopenconnect2 libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4
  libopencv-ml2.4 libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4 libp11-kit0 libp11-kit0:i386 libpam-winbind
  libpango-1.0-0 libpango1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libphonon4 libpkcs11-helper1
  libplasma-geolocation-interface4 libplasma3 libplasmagenericshell4 libpoppler-glib8 libpoppler-qt4-4 libpoppler43 libpopt0
  libpostproc52 libprocesscore4abi1 libprocessui4a libqgpgme1 libqtruby4shared2 libqtwebkit4 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-math libreoffice-report-builder-bin
  libreoffice-style-galaxy libreoffice-style-oxygen libreoffice-writer librsvg2-2 librsvg2-common libsdl1.2debian libselinux1
  libsemanage-common libsemanage1 libsepol1 libsmbclient libsmokebase3 libsmokeqtcore4-3 libsmokeqtdbus4-3 libsmokeqtgui4-3
  libsmokeqtnetwork4-3 libsmokeqtopengl4-3 libsmokeqtsql4-3 libsmokeqtsvg4-3 libsmokeqtwebkit4-3 libsmokeqtxml4-3 libsolid4
  libsoprano4 libspeex1 libspeexdsp1 libspice-server1 libsqlite3-0 libssl1.0.0 libssl1.0.0:i386 libstdc++6-4.6-dev
  libstdc++6-4.7-dev libswresample0 libswscale2 libsyndication4 libtag1c2a libtelepathy-qt4-2 libthai-data libthai0
  libthreadweaver4 libuniconf4.6 libupower-glib1 libva-x11-1 libva1 libvirtodbc0 libvlc5 libwavpack1 libwbclient0 libweather-ion6
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwpg-0.2-2 libwvstreams4.6-base
  libwvstreams4.6-extras libxcb-composite0 libxcb-damage0 libxcb-dri2-0 libxcb-dri2-0:i386 libxcb-dri2-0-dev libxcb-glx0
  libxcb-glx0:i386 libxcb-glx0-dev libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync0 libxcb-xfixes0
  libxcb-xtest0 libxcb-xv0 libxcb1 libxcb1:i386 libxcb1-dev libxnvctrl0 linux-headers-amd64 linux-image-amd64 linux-libc-dev make
  marble-data marble-plugins mplayer mplayerthumbs nepomuk-core-data nepomuk-core-runtime nvidia-alternative nvidia-detect
  nvidia-driver nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms nvidia-settings nvidia-support
  nvidia-vdpau-driver nvidia-xconfig okular openssh-client openssl oxygen-icon-theme p11-kit patch patchutils phonon
  phonon-backend-gstreamer phonon-backend-vlc plasma-dataengines-addons plasma-dataengines-workspace plasma-desktop plasma-netbook
  plasma-scriptengine-javascript plasma-scriptengine-python plasma-scriptengine-superkaramba plasma-widget-folderview
  plasma-widget-lancelot plasma-widgets-addons plasma-widgets-workspace plymouth-themes-solydk pm-utils poppler-utils
  print-manager printer-driver-escpr printer-driver-min12xxw printer-driver-pnm2ppa python-cups python-cupshelpers python-kde4
  python-nevow python-opencv python-qt4 python-qt4-dbus python-sip python-twisted-bin python-twisted-core python-twisted-web
  python-uno python3-pykde4 python3-pyqt4 python3-sip quassel-data-kde4 quassel-kde4 rsync ruby-locale ruby-qt4 ruby-qt4-webkit
  samba samba-common samba-common-bin smbclient solydxk-flashplugin-11 solydxk-softwaremanager soprano-daemon speex steam:i386
  system-config-printer-udev systemsettings thunderbird thunderbird-l10n-en-us uno-libs3 upower ure usbmuxd user-setup
  virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse wavpack wget
  winbind xserver-xorg-input-wacom xserver-xorg-video-nouveau xserver-xorg-video-nvidia

520 upgraded, 52 newly installed, 3 to remove and 0 not upgraded.
Need to get 593 MB of archives.
After this operation, 109 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
---------------
dv7-1270us fleabus #
fleabus@dv7-1270us ~ $ inxi -SGxxx
System:    Host: dv7-1270us Kernel: 3.11-2-amd64 x86_64 (64 bit, gcc: 4.8.1) 
           Desktop: KDE 4.11.4 (Qt 4.8.6) info: plasma-desktop dm: kdm Distro: SolydXK 1 testing
Graphics:  Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0 chip-ID: 10de:0649 
           X.Org: 1.14.3 driver: nvidia Resolution: 1920x1080@60.0hz 
           GLX Renderer: GeForce 9600M GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 319.72 Direct Rendering: Yes

dv7-1270us fleabus # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dv7-1270us fleabus # 

User avatar
Arjen Balfoort
Site Admin
Posts: 9423
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 30/11/2013 [TESTING]

Postby Arjen Balfoort » 06 Dec 2013 09:07

The repository has been updated with Santa's new packages: no packages held back!

Code: Select all

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libnepomukcleaner4 libtag1-rusxmms libtaskmanager4abi50
The following NEW packages will be installed:
  attr kde-base-artwork libasn1-8-heimdal libbasicusageenvironment0
  libboost-filesystem1.54.0 libboost-regex1.54.0 libboost-signals1.54.0
  libboost-thread1.54.0 libchromaprint0 libepub0 libfftw3-long3 libgme0
  libgroupsock1 libgssapi3-heimdal libhcrypto4-heimdal libhdb9-heimdal
  libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal
  libimobiledevice4 libkdc2-heimdal libkdecorations4abi2 libkrb5-26-heimdal
  libkwineffects1abi5 libkwinglutils1abi2 libldb1 liblivemedia16
  libplasmaclock4abi4 libproxy1 libquazip0 libroken18-heimdal libtag1-vanilla
  libtaskmanager4abi4 libusageenvironment1 libusbmuxd2 libvlccore7
  libwind0-heimdal libx264-140 libzip2 linux-headers-3.11-2-amd64
  linux-headers-3.11-2-common linux-image-3.11-2-amd64 linux-kbuild-3.11
  python-dnspython python-ldb python-samba python-talloc python-tdb
  samba-dsdb-modules samba-libs tdb-tools
The following packages will be upgraded:
  akonadi-backend-sqlite akonadi-server ark at-spi2-core bash-completion
  binfmt-support busybox console-tools cpp-4.6 cpp-4.7 dbus dbus-x11 debconf
  debconf-i18n digikam digikam-private-libs dnsmasq-base dolphin
  evolution-data-server-common ffmpeg firefox firefox-l10n-en-us
  fonts-arphic-uming fonts-opensymbol freerdp-x11 freespacenotifier g++-4.6
  g++-4.7 gcc-4.6 gcc-4.6-base gcc-4.7 gcc-4.7-base gcc-4.7-base:i386
  geoip-database gir1.2-pango-1.0 glib-networking glib-networking-services
  grep gsettings-desktop-schemas gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-x gtk2-engines-oxygen
  gtk2-engines-pixbuf gvfs gvfs-daemons gvfs-libs gwenview hostname hugin
  hugin-data hugin-tools ifupdown init-system-helpers initramfs-tools
  installation-report iso-codes kaddressbook kamera kate kate-data katepart
  kcalc kcharselect kde-baseapps-bin kde-baseapps-data kde-runtime
  kde-runtime-data kde-style-oxygen kde-wallpapers-default kde-window-manager
  kde-workspace kde-workspace-bin kde-workspace-data
  kde-workspace-kgreet-plugins kdebase-runtime kdelibs-bin kdelibs5-data
  kdelibs5-plugins kdenetwork-filesharing kdepasswd kdepim-runtime
  kdepimlibs-kio-plugins kdf kdm kdoctools kfind kget kgpg khelpcenter4
  kinfocenter kio-audiocd kipi-plugins klibc-utils klipper kmenuedit kmix
  knotes konqueror-nsplugins konsole kopete kppp krdc ksaneplugin kscreensaver
  kscreensaver-xsavers ksnapshot ksysguard ksysguardd ksystemlog ktorrent
  kwalletmanager kwrite libakonadi-calendar4 libakonadi-contact4
  libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadiprotocolinternals1 libatspi2.0-0 libavcodec54 libavdevice54
  libavfilter3 libavformat54 libavutil52 libbonobo2-0 libbonobo2-common
  libboost-date-time1.49.0 libboost-date-time1.54.0 libboost-filesystem1.49.0
  libboost-filesystem1.53.0 libboost-iostreams1.54.0
  libboost-program-options1.54.0 libboost-python1.49.0 libboost-python1.54.0
  libboost-regex1.53.0 libboost-signals1.53.0 libboost-system1.49.0
  libboost-system1.53.0 libboost-system1.54.0 libboost-thread1.53.0 libcddb2
  libcdio-cdda1 libcdio-paranoia1 libcdio13 libconsole libdbus-1-3
  libdbus-1-3:i386 libdlrestrictions1 libdrm-dev libdrm-intel1
  libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1
  libdrm-radeon1:i386 libdrm2 libdrm2:i386 libdvbpsi9 libelf1 libelf1:i386
  libept1.4.12 libexttextcat-2.0-0 libexttextcat-data libfftw3-3
  libfftw3-double3 libfftw3-single3 libfreerdp-plugins-standard libfreerdp1
  libgadu3 libgail18 libgcc-4.7-dev libgeoip1 libgnome2-perl libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgpgme++2 libgphoto2-2
  libgphoto2-port0 libgpod-common libgpod4 libgssdp-1.0-3
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libgupnp-1.0-4 libhsqldb-java libhtml-format-perl
  libhunspell-1.3-0 libicu48 libidl0 libio-socket-inet6-perl libiso9660-8
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0 libkabc4
  libkactivities-bin libkactivities-models1 libkactivities6 libkateinterfaces4
  libkatepartinterfaces4 libkcal4 libkcalcore4 libkcalutils4 libkcddb4
  libkcmutils4 libkcompactdisc4 libkdcraw-data libkdcraw22 libkde3support4
  libkdeclarative5 libkdecore5 libkdepim4 libkdesu5 libkdeui5 libkdewebkit5
  libkdnssd4 libkemoticons4 libkephal4abi1 libkexiv2-11 libkexiv2-data
  libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkimproxy4
  libkio5 libkipi-data libkipi11 libkjsapi4 libkjsembed4 libkldap4 libkleo4
  libklibc libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates libkonq5abi1
  libkontactinterface4 libkopete4 libkparts4 libkpimidentities4
  libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkqoauth0
  libkresources4 libkrosscore4 libksane-data libksane0 libkscreensaver5
  libksgrd4 libksignalplotter4 libktexteditor4 libkunitconversion4 libkutils4
  libkworkspace4abi2 libkxmlrpcclient4 libllvm3.3 libllvm3.3:i386
  libloudmouth1-0 libmailtransport4 libmarblewidget16 libmicroblog4
  libnepomuk4 libnepomukcore4 libnepomukquery4a libnepomukutils4
  libnepomukwidgets4abi1 libnspr4 libnspr4-0d libnss-winbind libnss3
  libnss3-1d libokularcore3 libopenconnect2 libp11-kit0 libp11-kit0:i386
  libpam-winbind libpango-1.0-0 libpango1.0-0 libpangocairo-1.0-0
  libpangoft2-1.0-0 libpangoxft-1.0-0 libphonon4 libpkcs11-helper1
  libplasma-geolocation-interface4 libplasma3 libplasmagenericshell4
  libpoppler-glib8 libpoppler-qt4-4 libpoppler43 libpopt0 libpostproc52
  libprocesscore4abi1 libprocessui4a libqgpgme1 libqtruby4shared2 libqtwebkit4
  libreoffice libreoffice-base libreoffice-base-core libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-writer librsvg2-2 librsvg2-common
  libsdl1.2debian libselinux1 libsemanage-common libsemanage1 libsepol1
  libsmbclient libsmokebase3 libsmokeqtcore4-3 libsmokeqtdbus4-3
  libsmokeqtgui4-3 libsmokeqtnetwork4-3 libsmokeqtopengl4-3 libsmokeqtsql4-3
  libsmokeqtsvg4-3 libsmokeqtwebkit4-3 libsmokeqtxml4-3 libsolid4 libspeex1
  libspeexdsp1 libspice-server1 libsqlite3-0 libssl1.0.0 libssl1.0.0:i386
  libstdc++6-4.6-dev libstdc++6-4.7-dev libswresample0 libswscale2
  libsyndication4 libtag1c2a libtelepathy-qt4-2 libthai-data libthai0
  libthreadweaver4 libuniconf4.6 libupower-glib1 libva-x11-1 libva1
  libvirtodbc0 libvlc5 libwavpack1 libwbclient0 libweather-ion6
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libwpg-0.2-2 libwvstreams4.6-base
  libwvstreams4.6-extras libxcb-composite0 libxcb-damage0 libxcb-dri2-0
  libxcb-dri2-0:i386 libxcb-dri2-0-dev libxcb-glx0 libxcb-glx0:i386
  libxcb-glx0-dev libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0
  libxcb-sync0 libxcb-xfixes0 libxcb-xtest0 libxcb-xv0 libxcb1 libxcb1:i386
  libxcb1-dev linux-headers-amd64 linux-image-amd64 linux-libc-dev make
  marble-data marble-plugins mplayer mplayerthumbs nepomuk-core-data
  nepomuk-core-runtime okular openssh-client openssl oxygen-icon-theme p11-kit
  patch patchutils phonon phonon-backend-gstreamer plasma-dataengines-addons
  plasma-dataengines-workspace plasma-desktop plasma-netbook
  plasma-scriptengine-javascript plasma-scriptengine-python
  plasma-scriptengine-superkaramba plasma-widget-folderview
  plasma-widgets-addons plasma-widgets-workspace plymouth-themes-solydk
  pm-utils poppler-utils print-manager printer-driver-escpr
  printer-driver-min12xxw printer-driver-pnm2ppa python-cups
  python-cupshelpers python-kde4 python-nevow python-qt4 python-qt4-dbus
  python-sip python-twisted-bin python-twisted-core python-twisted-web
  python-uno python3-pykde4 python3-pyqt4 python3-sip quassel-data-kde4
  quassel-kde4 rsync ruby-locale ruby-qt4 ruby-qt4-webkit samba samba-common
  samba-common-bin smbclient solydxk-flashplugin-11 solydxk-softwaremanager
  speex system-config-printer-udev systemsettings thunderbird
  thunderbird-l10n-en-us uno-libs3 upower ure usbmuxd user-setup
  virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common vlc vlc-data
  vlc-nox vlc-plugin-notify vlc-plugin-pulse wavpack wget winbind
  xserver-xorg-input-wacom xserver-xorg-video-nouveau
480 upgraded, 51 newly installed, 3 to remove and 0 not upgraded.
Need to get 556 MB of archives.
After this operation, 109 MB of additional disk space will be used.
Do you want to continue? [Y/n] 


SolydXK needs you!
Development | Testing | Translations

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 30/11/2013 [TESTING]

Postby fleabus » 06 Dec 2013 09:54

Fresh install from 11-25 iso, no nvidia yet, only a few post-install config changes.

...And no issues whatsoever, nothing was kept back, looks pretty much the same as yours, Schoelje.

I'm going to run it again, this time with [production] nvidia installed first.

Code: Select all

fleabus@dv7-1270us ~ $ inxi -SGrxxx
System:    Host: dv7-1270us Kernel: 3.10-3-amd64 x86_64 (64 bit, gcc: 4.7.3) 
           Desktop: KDE 4.11.3 (Qt 4.8.6) info: plasma-desktop dm: kdm Distro: SolydXK 1 testing
Graphics:  Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0 chip-ID: 10de:0649 
           X.Org: 1.14.3 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Gallium 0.4 on NV96 GLX Version: 3.0 Mesa 9.2.2 Direct Rendering: Yes
dv7-1270us fleabus # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  libnepomukcleaner4 libtag1-rusxmms libtaskmanager4abi50
The following NEW packages will be installed:
  attr kde-base-artwork libasn1-8-heimdal libbasicusageenvironment0
  libboost-filesystem1.54.0 libboost-regex1.54.0
  libboost-signals1.54.0 libboost-thread1.54.0 libchromaprint0
  libepub0 libfftw3-long3 libgme0 libgroupsock1 libgssapi3-heimdal
  libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal
  libheimntlm0-heimdal libhx509-5-heimdal libimobiledevice4
  libkdc2-heimdal libkdecorations4abi2 libkrb5-26-heimdal
  libkwineffects1abi5 libkwinglutils1abi2 libldb1 liblivemedia16
  libplasmaclock4abi4 libproxy1 libquazip0 libroken18-heimdal
  libtag1-vanilla libtaskmanager4abi4 libusageenvironment1
  libusbmuxd2 libvlccore7 libwind0-heimdal libx264-140 libzip2
  linux-headers-3.11-2-amd64 linux-headers-3.11-2-common
  linux-image-3.11-2-amd64 linux-kbuild-3.11 python-dnspython
  python-ldb python-samba python-talloc python-tdb
  samba-dsdb-modules samba-libs tdb-tools
The following packages will be upgraded:
  akonadi-backend-sqlite akonadi-server ark at-spi2-core
  bash-completion binfmt-support busybox console-tools cpp-4.6
  cpp-4.7 dbus dbus-x11 debconf debconf-i18n digikam
  digikam-private-libs dnsmasq-base dolphin
  evolution-data-server-common ffmpeg firefox firefox-l10n-en-us
  fonts-arphic-uming fonts-opensymbol freerdp-x11 freespacenotifier
  g++-4.6 g++-4.7 gcc-4.6 gcc-4.6-base gcc-4.7 gcc-4.7-base
  gcc-4.7-base:i386 geoip-database gir1.2-pango-1.0 glib-networking
  glib-networking-services grep gsettings-desktop-schemas
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-x
  gtk2-engines-oxygen gtk2-engines-pixbuf gvfs gvfs-daemons
  gvfs-libs gwenview hostname hugin hugin-data hugin-tools ifupdown
  init-system-helpers initramfs-tools installation-report iso-codes
  kaddressbook kamera kate kate-data katepart kcalc kcharselect
  kde-baseapps-bin kde-baseapps-data kde-runtime kde-runtime-data
  kde-style-oxygen kde-wallpapers-default kde-window-manager
  kde-workspace kde-workspace-bin kde-workspace-data
  kde-workspace-kgreet-plugins kdebase-runtime kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdenetwork-filesharing kdepasswd
  kdepim-runtime kdepimlibs-kio-plugins kdf kdm kdoctools kfind kget
  kgpg khelpcenter4 kinfocenter kio-audiocd kipi-plugins klibc-utils
  klipper kmenuedit kmix knotes konqueror-nsplugins konsole kopete
  kppp krdc ksaneplugin kscreensaver kscreensaver-xsavers ksnapshot
  ksysguard ksysguardd ksystemlog ktorrent kwalletmanager kwrite
  libakonadi-calendar4 libakonadi-contact4 libakonadi-kabc4
  libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadiprotocolinternals1 libatspi2.0-0 libavcodec54
  libavdevice54 libavfilter3 libavformat54 libavutil52 libbonobo2-0
  libbonobo2-common libboost-date-time1.49.0
  libboost-date-time1.54.0 libboost-filesystem1.49.0
  libboost-filesystem1.53.0 libboost-iostreams1.54.0
  libboost-program-options1.54.0 libboost-python1.49.0
  libboost-python1.54.0 libboost-regex1.53.0 libboost-signals1.53.0
  libboost-system1.49.0 libboost-system1.53.0 libboost-system1.54.0
  libboost-thread1.53.0 libcddb2 libcdio-cdda1 libcdio-paranoia1
  libcdio13 libconsole libdbus-1-3 libdbus-1-3:i386
  libdlrestrictions1 libdrm-dev libdrm-intel1 libdrm-intel1:i386
  libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1
  libdrm-radeon1:i386 libdrm2 libdrm2:i386 libdvbpsi9 libelf1
  libelf1:i386 libept1.4.12 libexttextcat-2.0-0 libexttextcat-data
  libfftw3-3 libfftw3-double3 libfftw3-single3
  libfreerdp-plugins-standard libfreerdp1 libgadu3 libgail18
  libgcc-4.7-dev libgeoip1 libgnome2-perl libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgpgme++2 libgphoto2-2
  libgphoto2-port0 libgpod-common libgpod4 libgssdp-1.0-3
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgupnp-1.0-4 libhsqldb-java
  libhtml-format-perl libhunspell-1.3-0 libicu48 libidl0
  libio-socket-inet6-perl libiso9660-8 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libkabc4 libkactivities-bin
  libkactivities-models1 libkactivities6 libkateinterfaces4
  libkatepartinterfaces4 libkcal4 libkcalcore4 libkcalutils4
  libkcddb4 libkcmutils4 libkcompactdisc4 libkdcraw-data libkdcraw22
  libkde3support4 libkdeclarative5 libkdecore5 libkdepim4 libkdesu5
  libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkephal4abi1
  libkexiv2-11 libkexiv2-data libkfile4 libkholidays4 libkhtml5
  libkidletime4 libkimap4 libkimproxy4 libkio5 libkipi-data
  libkipi11 libkjsapi4 libkjsembed4 libkldap4 libkleo4 libklibc
  libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates
  libkonq5abi1 libkontactinterface4 libkopete4 libkparts4
  libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4
  libkpty4 libkqoauth0 libkresources4 libkrosscore4 libksane-data
  libksane0 libkscreensaver5 libksgrd4 libksignalplotter4
  libktexteditor4 libkunitconversion4 libkutils4 libkworkspace4abi2
  libkxmlrpcclient4 libllvm3.3 libllvm3.3:i386 libloudmouth1-0
  libmailtransport4 libmarblewidget16 libmicroblog4 libnepomuk4
  libnepomukcore4 libnepomukquery4a libnepomukutils4
  libnepomukwidgets4abi1 libnspr4 libnspr4-0d libnss-winbind libnss3
  libnss3-1d libokularcore3 libopenconnect2 libp11-kit0
  libp11-kit0:i386 libpam-winbind libpango-1.0-0 libpango1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangoxft-1.0-0 libphonon4
  libpkcs11-helper1 libplasma-geolocation-interface4 libplasma3
  libplasmagenericshell4 libpoppler-glib8 libpoppler-qt4-4
  libpoppler43 libpopt0 libpostproc52 libprocesscore4abi1
  libprocessui4a libqgpgme1 libqtruby4shared2 libqtwebkit4
  libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-kde libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-writer librsvg2-2
  librsvg2-common libsdl1.2debian libselinux1 libsemanage-common
  libsemanage1 libsepol1 libsmbclient libsmokebase3
  libsmokeqtcore4-3 libsmokeqtdbus4-3 libsmokeqtgui4-3
  libsmokeqtnetwork4-3 libsmokeqtopengl4-3 libsmokeqtsql4-3
  libsmokeqtsvg4-3 libsmokeqtwebkit4-3 libsmokeqtxml4-3 libsolid4
  libspeex1 libspeexdsp1 libspice-server1 libsqlite3-0 libssl1.0.0
  libssl1.0.0:i386 libstdc++6-4.6-dev libstdc++6-4.7-dev
  libswresample0 libswscale2 libsyndication4 libtag1c2a
  libtelepathy-qt4-2 libthai-data libthai0 libthreadweaver4
  libuniconf4.6 libupower-glib1 libva-x11-1 libva1 libvirtodbc0
  libvlc5 libwavpack1 libwbclient0 libweather-ion6
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0
  libwebkitgtk-3.0-common libwpg-0.2-2 libwvstreams4.6-base
  libwvstreams4.6-extras libxcb-composite0 libxcb-damage0
  libxcb-dri2-0 libxcb-dri2-0:i386 libxcb-dri2-0-dev libxcb-glx0
  libxcb-glx0:i386 libxcb-glx0-dev libxcb-randr0 libxcb-render0
  libxcb-shape0 libxcb-shm0 libxcb-sync0 libxcb-xfixes0
  libxcb-xtest0 libxcb-xv0 libxcb1 libxcb1:i386 libxcb1-dev
  linux-headers-amd64 linux-image-amd64 linux-libc-dev make
  marble-data marble-plugins mplayer mplayerthumbs nepomuk-core-data
  nepomuk-core-runtime okular openssh-client openssl
  oxygen-icon-theme p11-kit patch patchutils phonon
  phonon-backend-gstreamer plasma-dataengines-addons
  plasma-dataengines-workspace plasma-desktop plasma-netbook
  plasma-scriptengine-javascript plasma-scriptengine-python
  plasma-scriptengine-superkaramba plasma-widget-folderview
  plasma-widgets-addons plasma-widgets-workspace
  plymouth-themes-solydk pm-utils poppler-utils print-manager
  printer-driver-escpr printer-driver-min12xxw
  printer-driver-pnm2ppa python-cups python-cupshelpers python-kde4
  python-nevow python-qt4 python-qt4-dbus python-sip
  python-twisted-bin python-twisted-core python-twisted-web
  python-uno python3-pykde4 python3-pyqt4 python3-sip
  quassel-data-kde4 quassel-kde4 rsync ruby-locale ruby-qt4
  ruby-qt4-webkit samba samba-common samba-common-bin smbclient
  solydxk-flashplugin-11 solydxk-softwaremanager speex
  system-config-printer-udev systemsettings thunderbird
  thunderbird-l10n-en-us uno-libs3 upower ure usbmuxd user-setup
  virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common vlc
  vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse wavpack wget
  winbind xserver-xorg-input-wacom xserver-xorg-video-nouveau
480 upgraded, 51 newly installed, 3 to remove and 0 not upgraded.
Need to get 556 MB of archives.
After this operation, 109 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
<-snip->
fleabus@dv7-1270us ~ $ inxi -SGxxx
System:    Host: dv7-1270us Kernel: 3.11-2-amd64 x86_64 (64 bit, gcc: 4.8.1) 
           Desktop: KDE 4.11.4 (Qt 4.8.6) info: plasma-desktop dm: kdm Distro: SolydXK 1 testing
Graphics:  Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0 chip-ID: 10de:0649 
           X.Org: 1.14.3 drivers: nouveau (unloaded: fbdev,vesa) Resolution: 1920x1080@60.0hz 
           GLX Renderer: Gallium 0.4 on NV96 GLX Version: 3.0 Mesa 9.2.2 Direct Rendering: Yes


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 4 guests