[Solved] Thunar File delete does not use Trash

Questions specific to the Xfce DE go here
t0psy
Posts: 39
Joined: 21 Mar 2014 16:01

[Solved] Thunar File delete does not use Trash

Postby t0psy » 30 Oct 2014 10:02

When I delete a file using Thunar it does not go to the Trash/Wastebasket.
My Wastebasket icon is always empty.

I have 2 systems and both behave identically.

I have Xubuntu installed on another computer and the "Rubbish Bin" as it is called behaves how I would expect.

Is SolydX configured to bypass the Trash system or are my Solyd systems unusual?

When I look in /home/dave/.local/share/Trash/files/
it is always empty

In Thunar trash:/// is also always empty.

Thunar is 1.6.3 on all my systems.

Reading in other forums, some people go to great lengths to setup auto-delete but it would be nice to have the option.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Thunar File delete does not use Trash

Postby Zill » 30 Oct 2014 12:10

t0psy: Right-click on the "panel" at the bottom of the screen and, using the "Add new menu items" option, add the "Trash Applet" (or possibly "Wastebasket Applet" according to your locale).

This should then show the familiar "trash can" at the bottom of the screen. See if it contains items you have previously deleted.

If so, then see if "Trash" is visible in the Thunar "Devices, Places" right-click menu. You can then enable or disable visibility of this in Thunar as required.

t0psy
Posts: 39
Joined: 21 Mar 2014 16:01

Re: Thunar File delete does not use Trash

Postby t0psy » 30 Oct 2014 16:57

Zill wrote:t0psy: Right-click on the "panel" at the bottom of the screen and, using the "Add new menu items" option, add the "Trash Applet" (or possibly "Wastebasket Applet" according to your locale).

This should then show the familiar "trash can" at the bottom of the screen. See if it contains items you have previously deleted.
I have done this first step and the applet appears on the task bar.
However when I mouse over it or right click "wastebasket is empty" is displayed, even after a fresh delete of a file.
Zill wrote:If so, then see if "Trash" is visible in the Thunar "Devices, Places" right-click menu. You can then enable or disable visibility of this in Thunar as required.
I am not sure where I find this next step, I can't find any reference to devices in thunar.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Thunar File delete does not use Trash

Postby Zill » 30 Oct 2014 20:42

t0psy wrote:...I have done this first step and the applet appears on the task bar.
However when I mouse over it or right click "wastebasket is empty" is displayed, even after a fresh delete of a file.
Puzzling! This should show the files you have "deleted". I will try to research this further.
Zill wrote:If so, then see if "Trash" is visible in the Thunar "Devices, Places" right-click menu. You can then enable or disable visibility of this in Thunar as required.
t0psy wrote:...I am not sure where I find this next step, I can't find any reference to devices in thunar.
This is a screendump of my Thunar showing the Wastebasket option in the Devices/Places right-click menu...
Thunar_ Devices.png

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Thunar File delete does not use Trash

Postby Zill » 30 Oct 2014 21:22

t0psy: The XFCE Wiki advises...
Can I disable the trash?
No, you can not. But you can do for example:
1. use 'SHIFT + del' to bypass the trash bin and immediately delete something for real.
2. use cron to clean the trash every now and then.
3. or create custom action for permanent delete(like in gnome) with action: rm %f then in context menu you'll have button “permanent delete”
Have you created a Thunar custom action to directly delete files?

I understand that gvfs is needed for trash - have you got this installed?

Code: Select all

apt policy gvfs
Also, you could try killing the Thunar daemon with the "-q" option...

Code: Select all

thunar -q

t0psy
Posts: 39
Joined: 21 Mar 2014 16:01

Re: Thunar File delete does not use Trash

Postby t0psy » 30 Oct 2014 22:26

I now see the right click it is on the "devices" name.
Yes wastebasket is ticked.
I didn't know this menu option existed.

Zill wrote:t0psy: The XFCE Wiki advises...
Can I disable the trash?
No, you can not. But you can do for example:
1. use 'SHIFT + del' to bypass the trash bin and immediately delete something for real.
2. use cron to clean the trash every now and then.
3. or create custom action for permanent delete(like in gnome) with action: rm %f then in context menu you'll have button “permanent delete”
Have you created a Thunar custom action to directly delete files?

I understand that gvfs is needed for trash - have you got this installed?

Code: Select all

apt policy gvfs
Also, you could try killing the Thunar daemon with the "-q" option...

Code: Select all

thunar -q

No custom action to disable trash
Yes gvfs is installed

BINGO killing the Thunar daemon with thunar -q did the trick.
When I delete a file it no longer gives me the warning that the file will be deleted irretrievably and the wastebasket has items in it that can be emptied.

The fix also survived a reboot so I will mark this issue as solved.

Thanks very much for all the help guys it has cured the problem.
I am curios as to why the thunar daemon was running anyway.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: [Solved] Thunar File delete does not use Trash

Postby Zill » 30 Oct 2014 22:48

t0psy: Great! I'm very pleased you have got it working. :-)


Return to “Xfce specific (SolydX)”

Who is online

Users browsing this forum: No registered users and 0 guests