HE to Jessie upgrade

Important informations about SolydXK including releases notes, forum rules and other anouncements
User avatar
grizzler
Posts: 2171
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: HE to Jessie upgrade

Postby grizzler » 16 Mar 2015 17:33

That's a bit of an odd warning, because those two files aren't symlinks in the most recent version of that package. Maybe you should reinstall it:

Code: Select all

apt install --reinstall solydk-system-adjustments
and if you're asked whether you want to keep any old versions of configuration files, choose not to.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: HE to Jessie upgrade

Postby Zill » 16 Mar 2015 17:50

grizzler wrote:...and if you're asked whether you want to keep any old versions of configuration files, choose not to.
I appreciate that this advice might only apply to help resolve this particular problem.

However, the default SolydXK advice has always been "You might be asked to replace certain configuration files. It is recommended to keep the currently installed file (default selected)."

http://solydxk.com/2015/01/

In what circumstances would you recommend replacing the currently installed file with a new one?

User avatar
grizzler
Posts: 2171
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: HE to Jessie upgrade

Postby grizzler » 16 Mar 2015 18:01

In general when keeping the old one causes problems... ;)

Seriously, I don't have a clear answer to that. It is recommended to keep the old one. That just doesn't seem right in this case.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: HE to Jessie upgrade

Postby Zill » 16 Mar 2015 20:03

Thanks grizzler. I thought that might be the case but felt it necessary to ask the question. :-)

I must admit that, as a "serial upgrader", I keep my distros running until I eventually retire them to use a different one. I do worry from time to time about the new config files that sometimes arrive with newer software and think I might be missing out on some wonderful new feature.

Still, I firmly believe in "if it ain't broke don't fix it" and so I just keep bumbling along with my ancient config files... ;-)

Tim Robberts
Posts: 5
Joined: 12 May 2014 18:10

Re: HE to Jessie upgrade

Postby Tim Robberts » 17 Mar 2015 06:00

grizzler wrote:In general when keeping the old one causes problems... ;)

Seriously, I don't have a clear answer to that. It is recommended to keep the old one. That just doesn't seem right in this case.
:lol:

Thank you very much grizzler! I will try your advice. To be safe I will just clone my drive before I do it ;)

Tim Robberts
Posts: 5
Joined: 12 May 2014 18:10

Re: HE to Jessie upgrade

Postby Tim Robberts » 19 Mar 2015 07:53

grizzler wrote:That's a bit of an odd warning, because those two files aren't symlinks in the most recent version of that package. Maybe you should reinstall it:

Code: Select all

apt install --reinstall solydk-system-adjustments
and if you're asked whether you want to keep any old versions of configuration files, choose not to.
Hi grizzler,

I followed your advice and here is the output of doing so. It never asked me about keeping my old configuration file but from looking at the output it still seems I have this odd warning.

Code: Select all

Tim@Tim-3 ~ $ apt install --reinstall solydk-system-adjustments
[sudo] password for Tim: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  evolution-common evolution-data-server libavutil53 libcamel-1.2-49 libchamplain-0.12-0 libchamplain-gtk-0.12-0 libebackend-1.2-7 libebook-1.2-14 libebook-contacts-1.2-0
  libecal-1.2-16 libedata-book-1.2-20 libedata-cal-1.2-23 libedataserver-1.2-18 libevolution libexif12:i386 libgd3:i386 libgdata-common libgdata19 libgeocode-glib0 libgphoto2-6:i386
  libgphoto2-port10:i386 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgtkspell3-3-0 libgweather-3-6 libgweather-common libinput3 libjs-excanvas libjs-mochikit
  libllvm3.4 libllvm3.4:i386 libltdl7:i386 liboauth0 libphonenumber6 libprotobuf9 libpst4 libswt-cairo-gtk-3-jni libswt-gtk-3-java libswt-gtk-3-jni libsystemd-daemon0
  libsystemd-id128-0 libsystemd-id128-0:i386 libsystemd-journal0 libsystemd-journal0:i386 libtiff5:i386 libusb-1.0-0:i386 libvpx1:i386 libxpm4:i386 libytnef0
  linux-headers-3.14-2-amd64 linux-headers-3.14-2-common linux-image-3.14-2-amd64 linux-kbuild-3.14 par2 python-cheetah python-yenc python3-packagekit tix
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/2,513 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 295727 files and directories currently installed.)
Preparing to unpack .../solydk-system-adjustments_2.0.8_all.deb ...
Unpacking solydk-system-adjustments (2.0.8) over (2.0.8) ...
dpkg: warning: solydk-system-adjustments: config file '/etc/skel/.gtkrc-2.0-kde4' is a circular link
 (= '/etc/skel/.gtkrc-2.0')
dpkg: warning: solydk-system-adjustments: config file '/etc/skel/.gtkrc-2.0' is a circular link
 (= '/etc/skel/.gtkrc-2.0-kde4')
Processing triggers for fontconfig (2.11.0-6.3) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for solydxk-system (2.0.6) ...
Setting up solydk-system-adjustments (2.0.8) ...
dpkg: warning: solydk-system-adjustments: config file '/etc/skel/.gtkrc-2.0' is a circular link
 (= '/etc/skel/.gtkrc-2.0-kde4')
dpkg: warning: solydk-system-adjustments: config file '/etc/skel/.gtkrc-2.0-kde4' is a circular link
 (= '/etc/skel/.gtkrc-2.0')
Generating grub configuration file ...
Found background image: grubbg.png
Found linux image: /boot/vmlinuz-3.16.0-4-amd64                                                                                 
Found initrd image: /boot/initrd.img-3.16.0-4-amd64                                                                              
Found linux image: /boot/vmlinuz-3.16-2-amd64                                                                                    
Found initrd image: /boot/initrd.img-3.16-2-amd64                                                                                  
Found linux image: /boot/vmlinuz-3.14-2-amd64                                                                                                                    
Found initrd image: /boot/initrd.img-3.14-2-amd64                                                                                                                             
Found linux image: /boot/vmlinuz-3.11-2-amd64                                                                                                                                       
Found initrd image: /boot/initrd.img-3.11-2-amd64
Found linux image: /boot/vmlinuz-3.10-3-amd64
Found initrd image: /boot/initrd.img-3.10-3-amd64
mount: unknown filesystem type 'crypto_LUKS'
done
Tim@Tim-3 ~ $ 

User avatar
Arjen Balfoort
Site Admin
Posts: 9283
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: HE to Jessie upgrade

Postby Arjen Balfoort » 19 Mar 2015 08:48

For some reason /etc/skel/.gtkrc-2.0 and /etc/skel/.gtkrc-2.0-kde are symbolic links and are pointing to each other.
Fix this with these commands:

Code: Select all

sudo rm /etc/skel/.gtkrc-2.0*
sudo apt install --reinstall solydk-system-adjustments


SolydXK needs you!
Development | Testing | Translations

Tim Robberts
Posts: 5
Joined: 12 May 2014 18:10

Re: HE to Jessie upgrade

Postby Tim Robberts » 23 Mar 2015 11:34

Thank you very much Schoelje I think it worked! I will put your advice in my notes on how to fix a problem like this for the future.

Of course it told me the default was to keep my current version but I knew that was wrong so replaced it with the " install the package maintainer's version" after running the "D" option to show the diff. :D

User avatar
Arjen Balfoort
Site Admin
Posts: 9283
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: HE to Jessie upgrade

Postby Arjen Balfoort » 23 Mar 2015 11:42

I'm glad it worked.


SolydXK needs you!
Development | Testing | Translations

User avatar
Gonzalo_VC
Posts: 321
Joined: 07 May 2013 13:25
Location: SouthAmerica

Re: Sources.list

Postby Gonzalo_VC » 04 May 2015 21:26

Sorry, been out for a while.
For ourolder installations of SolydX Home 32 bits (no chance to run 64 here), are these repos valid:

deb http://repository.solydxk.nl/ solydxk main upstream import
deb http://ftp.debian.org/debian jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free

Don't be a pirate, nor a slave. Use GNU/Linux!
GNU/Linux user 451206
SolydXK, GALPon MiniNo, PCLinuxOS, Xubuntu



User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Sources.list

Postby Zill » 04 May 2015 22:08

Gonzalo_VC: The repos you have listed are the same ones I currently use for my SolydX 32-bit install. As far as I know, they have not been superseded.

Note that, now Jessie is the new Debian Stable, the official SolydXK edition has dropped the "Home" suffix as this is the only edition until the Enthusiasts Edition (based on Debian Testing) is released by the community.

User avatar
Gonzalo_VC
Posts: 321
Joined: 07 May 2013 13:25
Location: SouthAmerica

Re: Sources.list

Postby Gonzalo_VC » 05 May 2015 00:12

Zill wrote:Gonzalo_VC: The repos you have listed are the same ones I currently use for my SolydX 32-bit install. As far as I know, they have not been superseded.
Note that, now Jessie is the new Debian Stable, the official SolydXK edition has dropped the "Home" suffix as this is the only edition until the Enthusiasts Edition (based on Debian Testing) is released by the community.
Yea, thanks, Zill.
I read another part of this forum and am doing the dist-upgrade to Jessie... wish me luck :mrgreen: I don't know what to expect after upgrading and rebooting (will the system look like SolydXK, yet?).
It's a netbook from one of my "offspring" (people I recommend and install them GNU/Linux). The Atom processor, even if some models are dual-thread, rather run 32 bits than 64 bits. Hence, I have to stick to 32 bits Debian here, and not the newer SolydXK versions, that are 64 bits only.

Don't be a pirate, nor a slave. Use GNU/Linux!
GNU/Linux user 451206
SolydXK, GALPon MiniNo, PCLinuxOS, Xubuntu



User avatar
Gonzalo_VC
Posts: 321
Joined: 07 May 2013 13:25
Location: SouthAmerica

Re: Sources.list

Postby Gonzalo_VC » 05 May 2015 02:50

OK. I did it, took a long timeand I got this: (what does it mean? Is something missing? -f install did not solve it!)

This is not resolved:

Code: Select all

Os pacotes a seguir serão atualizados: (=the following packages will be updated)
  a2ps accountsservice acl acpi-support-base acpid alsa-base alsa-utils
  amd64-microcode anacron apt apt-listchanges apt-utils apt-xapian-index
  aptdaemon aptdaemon-data aptitude aptitude-common arj aspell aspell-en at
  at-spi2-core autopoint b43-fwcutter baobab bash bash-completion bc
  binfmt-support bluez bluez-cups browser-plugin-vlc bsd-mailx bsdmainutils
  bsdutils busybox ca-certificates ca-certificates-java console-data
  console-setup console-setup-linux consolekit coreutils cowsay cpio cpp-4.8
  crda cron cryptsetup-bin cups-browsed cups-pk-helper cups-ppdc dash dbus
  dbus-x11 dc dconf-gsettings-backend dconf-service ddm debconf debconf-i18n
  debian-archive-keyring debian-faq debianutils deborphan debugedit
  desktop-base dh-python dialog diffstat diffutils dkms dmidecode dmsetup
  dnet-common doc-debian dosfstools e2fslibs e2fsprogs easy-rsa eject enchant
  ethtool evince evince-common exaile exiftran exim4 exim4-base exim4-config
  exim4-daemon-light exo-utils fancontrol file findutils firmware-atheros
  firmware-b43-installer firmware-b43legacy-installer firmware-bnx2
  firmware-bnx2x firmware-brcm80211 firmware-intelwimax firmware-ipw2x00
  firmware-ivtv firmware-iwlwifi firmware-libertas firmware-linux
  firmware-linux-free firmware-linux-nonfree firmware-qlogic firmware-ralink
  firmware-realtek fonts-dejavu fonts-dejavu-core fonts-dejavu-extra
  fonts-droid fonts-freefont-ttf fonts-liberation fonts-lyx fonts-opensymbol
  fonts-sil-gentium fonts-sil-gentium-basic fonts-stix
  foomatic-db-compressed-ppds ftp fuse galculator gawk gcc-4.8 gcc-4.8-base
  gconf-service gconf2 gconf2-common gcr geoip-database gettext gettext-base
  ghostscript gimp gimp-data gir1.2-atk-1.0 gir1.2-clutter-gst-1.0
  gir1.2-evince-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-gmenu-3.0
  gir1.2-gnomekeyring-1.0 gir1.2-gst-plugins-base-0.10 gir1.2-gstreamer-0.10
  gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-json-1.0 gir1.2-notify-0.7
  gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-vte-2.90 gksu
  gnome-accessibility-themes gnome-desktop3-data gnome-icon-theme
  gnome-icon-theme-symbolic gnome-keyring gnome-user-guide gnupg gnupg-agent
  gnupg2 gpgv grep groff-base grub-common grub-pc grub-pc-bin grub2-common
  gsettings-desktop-schemas gstreamer0.10-alsa gstreamer0.10-gconf
  gstreamer0.10-nice gstreamer0.10-plugins-base gstreamer0.10-plugins-good
  gstreamer0.10-pulseaudio gstreamer0.10-x gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good gstreamer1.0-x gtk2-engines gtk2-engines-oxygen
  gtk2-engines-pixbuf gtk3-engines-oxygen gtkhash gtkhash-common gzip
  hardening-includes hardinfo hdparm hicolor-icon-theme host hostname hplip
  hplip-data hwdata ifupdown imagemagick-common info initramfs-tools
  install-info intel-microcode inxi iproute iproute2 iptables iputils-ping
  iso-codes iucode-tool iw java-common kbd keyboard-configuration keyutils
  klibc-utils kmod krb5-locales less liba52-0.7.4 libaa1 libaacs0
  libaccountsservice0 libacl1 libao-common libao4 libappindicator1
  libappindicator3-1 libarchive-extract-perl libarchive-zip-perl libarchive13
  libasan0 libasound2 libasound2-data libaspell15 libasprintf-dev
  libasprintf0c2 libassuan0 libasyncns0 libatasmart4 libatk-bridge2.0-0
  libatk-wrapper-java libatk-wrapper-java-jni libatkmm-1.6-1 libatspi2.0-0
  libattr1 libaudio2 libaudit-common libaudit1 libauthen-sasl-perl
  libavahi-client3 libavahi-common-data libavahi-common3 libavahi-core7
  libavahi-glib1 libbabl-0.1-0 libblkid1 libbluetooth3 libbonoboui2-common
  libbsd0 libburn4 libcaca0 libcairo-gobject2 libcairomm-1.0-1
  libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0
  libcanberra-gtk3-module libcanberra0 libcap-ng0 libcap2 libcap2-bin
  libcdaudio1 libcddb2 libcdio-cdda1 libcdio-paranoia1 libcdio13
  libck-connector0 libcloog-isl4 libclutter-1.0-common libcogl-common
  libcomerr2 libcroco3 libcryptsetup4 libcrystalhd3 libcurl3-gnutls
  libcwidget3 libdaemon0 libdatrie1 libdbus-1-3 libdbus-glib-1-2
  libdbusmenu-glib4 libdbusmenu-gtk3-4 libdbusmenu-gtk4 libdc1394-22 libdconf1
  libdee-1.0-4 libdevmapper-event1.02.1 libdevmapper1.02.1 libdirac-encoder0
  libdjvulibre-text libdjvulibre21 libdrm-intel1 libdrm-nouveau2
  libdrm-radeon1 libdrm2 libdvbpsi9 libdvdcss2 libdvdnav4 libdvdread4 libedit2
  libee0 libelf1 libelfg0 libemail-valid-perl libenca0 libenchant1c2a
  libept1.4.12 libestr0 libevdocument3-4 libevent-2.0-5 libevview3-3
  libexempi3 libexif12 libexo-1-0 libexo-common libexo-helpers libexpat1
  libexttextcat-2.0-0 libexttextcat-data libfam0 libfarstream-0.1-0 libffi6
  libfile-desktopentry-perl libfile-mimeinfo-perl libflac8 libflite1
  libfontembed1 libfontenc1 libfreetype6 libfribidi0 libfs6 libfuse2 libgail18
  libgarcon-1-0 libgarcon-common libgc1c2 libgcc-4.8-dev libgck-1-0
  libgconf-2-4 libgconf2-4 libgcr-3-1 libgcr-3-common libgcr-base-3-1
  libgcr-ui-3-1 libgd3 libgdbm3 libgdome2-cpp-smart0c2a libgee2 libgeoclue0
  libgeoip1 libgettextpo-dev libgettextpo0 libgif4 libgimp2.0 libgksu2-0
  libglade2-0 libglib2.0-data libglibmm-2.4-1c2a libglu1-mesa libgmpxx4ldbl
  libgnome-keyring-common libgnome-keyring0 libgnome-menu-3-0 libgnome2-common
  libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgnutls-openssl27 libgpgme11
  libgphoto2-l10n libgpm2 libgraphite2-3 libgs9 libgs9-common libgsf-1-114
  libgsf-1-common libgssdp-1.0-3 libgstreamer-plugins-base0.10-0
  libgstreamer0.10-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtkhotkey1
  libgtkmm-2.4-1c2a libgtkmm-3.0-1 libgtksourceview-3.0-1
  libgtksourceview-3.0-common libgtksourceview2.0-0 libgtksourceview2.0-common
  libgtkspell0 libgtop2-7 libgudev-1.0-0 libgupnp-1.0-4 libgupnp-igd-1.0-4
  libgusb2 libgutenprint2 libgxps2 libhpmud0 libhtml-format-perl
  libhtml-template-perl libhtml-tree-perl libhttp-cookies-perl libhyphen0
  libice-dev libice6 libidl0 libidn11 libiec61883-0 libijs-0.35 libilmbase6
  libindicate5 libindicator3-7 libindicator7 libio-html-perl
  libio-socket-inet6-perl libio-socket-ssl-perl libio-string-perl
  libipc-system-simple-perl libisl10 libiso9660-8 libisofs6 libjack-jackd2-0
  libjasper1 libjbig0 libjson-c2 libjson-glib-1.0-0 libjson-glib-1.0-common
  libjson0 libjte1 libkate1 libkeybinder0 libklibc libkmod2 libkpathsea6
  libksba8 liblangtag-common liblangtag1 libldap-2.4-2 liblensfun-data
  liblensfun0 liblightdm-gobject-1-0 liblircclient0 libloudmouth1-0 liblqr-1-0
  libltdl7 liblua5.1-0 liblua5.2-0 liblvm2app2.2 liblwp-protocol-https-perl
  liblzo2-2 libmagic1 libmailtools-perl libmeanwhile1 libmhash2 libmimic0
  libmms0 libmng1 libmnl0 libmodplug1 libmodule-pluggable-perl libmount1
  libmpc3 libmpcdec6 libmpeg2-4 libmtdev1 libmtp-common libmtp-runtime libmtp9
  libmysqlclient18 libmythes-1.2-0 libnautilus-extension1a libneon27-gnutls
  libnet-domain-tld-perl libnet-http-perl libnetpbm10 libnewt0.52
  libnfnetlink0 libnice10 libnl-3-200 libnl-genl-3-200 libnotify-bin
  libnotify4 libnspr4 libnspr4-0d libnss-mdns libnss3 libnss3-1d libofa0
  libogg0 liboobs-1-5 libopenal-data libopenal1 libopencore-amrnb0
  libopencore-amrwb0 libopenexr6 libopenjpeg2 libopenraw1 libopenvg1-mesa
  libopts25 libopus0 libpam-cap libpam-ck-connector libpam-gnome-keyring
  libpam-modules libpam-modules-bin libpam-runtime libpam0g libpangomm-1.4-1
  libpangox-1.0-0 libpaper-utils libpaper1 libparse-debianchangelog-perl
  libpcap0.8 libpciaccess0 libpcsclite1 libphonon4 libpipeline1 libpixman-1-0
  libpkcs11-helper1 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpoppler-glib8 libpopt0 libpth20
  libpthread-stubs0-dev libpulse-mainloop-glib0 libpulse0 libpulsedsp
  libpurple-bin libpython-stdlib libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libqpdf13 libqt4-dbus libqt4-declarative libqt4-designer
  libqt4-help libqt4-network libqt4-script libqt4-scripttools libqt4-sql
  libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns
  libqtcore4 libqtdbus4 libqtgui4 librarian0 libraw1394-11 librecode0
  libreoffice-help-pt-br libreoffice-l10n-pt-br libreoffice-pdfimport
  libreoffice-report-builder-bin librest-0.7-0 librpm3 librpmbuild3 librpmio3
  librpmsign1 librsvg2-2 librsvg2-common libsamplerate0 libsane-hpaio
  libsasl2-modules libschroedinger-1.0-0 libsdl-image1.2 libsdl1.2debian
  libsecret-1-0 libsecret-common libsemanage-common libsemanage1 libsensors4
  libsepol1 libservlet2.5-java libsexy2 libsgutils2-2 libsidplay1
  libsigc++-2.0-0c2a libsigsegv2 libslang2 libslp1 libsm-dev libsm6
  libsndfile1 libsnmp-base libsoundtouch0 libsoup-gnome2.4-1 libspandsp2
  libspectre1 libspeex1 libspeexdsp1 libsqlite3-0 libss2 libssh2-1 libssl1.0.0
  libstartup-notification0 libswitch-perl libsystemd-daemon0 libsystemd-login0
  libtag1-vanilla libtag1c2a libtagc0 libtalloc2 libtar0 libtbb2 libtdb1
  libtelepathy-glib0 libtevent0 libtext-levenshtein-perl
  libtext-unidecode-perl libthai-data libthai0 libtheora0 libthunarx-2-0
  libtidy-0.99-0 libtiff5 libtimedate-perl libtokyocabinet9 libtumbler-1-0
  libtwolame0 libudev1 libudisks2-0 libuniconf4.6 libunique-1.0-0
  libunistring0 libupnp6 liburi-perl libusb-0.1-4 libusb-1.0-0 libustr-1.0-1
  libuuid1 libv4l-0 libv4lconvert0 libva-x11-1 libvcdinfo0 libvisual-0.4-0
  libvorbis0a libvorbisenc2 libvorbisfile3 libvpx1 libvte-2.90-9
  libvte-2.90-common libwavpack1 libwayland-server0
  libwebrtc-audio-processing-0 libwildmidi-config libwildmidi1 libwmf0.2-7
  libwnck-common libwnck22 libwrap0 libwv-1.2-4 libwvstreams4.6-base
  libwvstreams4.6-extras libwww-perl libx11-6 libx11-data libx11-dev
  libx11-doc libx11-protocol-perl libx11-xcb1 libxapian22 libxaw7
  libxcb-composite0 libxcb-dri2-0 libxcb-glx0 libxcb-keysyms1 libxcb-randr0
  libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-util0 libxcb-xfixes0
  libxcb-xv0 libxcb1 libxcb1-dev libxcursor1 libxdamage1 libxdmcp-dev
  libxdmcp6 libxext6 libxfce4ui-1-0 libxfce4ui-utils libxfce4util-bin
  libxfce4util-common libxfce4util6 libxfconf-0-2 libxfixes3 libxfont1 libxft2
  libxi6 libxinerama1 libxml-namespacesupport-perl libxml-twig-perl libxml2
  libxmu6 libxmuu1 libxpm4 libxrandr2 libxrender1 libxres1 libxslt1.1
  libxt-dev libxt6 libxtables10 libxtst6 libxv1 libxvmc1 libxxf86dga1
  libxxf86vm1 libyajl2 libyelp0 libzbar0 libzephyr4 libzvbi-common libzvbi0
  lightdm lightdm-gtk-greeter lightdm-manager lintian linux-libc-dev
  lm-sensors login logrotate lpr lsb-base lsb-release lxtask m4 make man-db
  manpages manpages-dev menu mesa-utils mime-support minissdpd
  mobile-broadband-provider-info module-init-tools multiarch-support
  murrine-themes mutt mysql-common nano nautilus-data ncurses-base
  ncurses-term ndiswrapper-common ndiswrapper-dkms ndiswrapper-utils-1.9
  net-tools netbase netcat-traditional netpbm ntfs-3g ntp nvidia-detect
  openjdk-7-jdk openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib
  openprinting-ppds openssh-client openssl openvpn os-prober oxygen-icon-theme
  p7zip-full passwd pastebinit patch patchutils pavucontrol pinentry-gtk2
  pm-utils poppler-data poppler-utils powermgmt-base ppp printer-driver-c2050
  printer-driver-c2esp printer-driver-cjet printer-driver-escpr
  printer-driver-gutenprint printer-driver-hpcups printer-driver-hpijs
  printer-driver-min12xxw printer-driver-pnm2ppa printer-driver-postscript-hp
  printer-driver-ptouch printer-driver-sag-gdi printer-driver-splix procmail
  psmisc psutils pulseaudio pulseaudio-module-x11 pulseaudio-utils python
  python-appindicator python-apt python-apt-common python-aptdaemon
  python-aptdaemon.gtk3widgets python-chardet python-configobj python-cups
  python-cupshelpers python-dbus python-debian python-debianbts python-geoip
  python-gi python-glade2 python-gobject python-gtk2 python-libxml2
  python-minimal python-mmkeys python-mutagen python-notify python-numpy
  python-pexpect python-pkg-resources python-pycurl python-qt4 python-renderpm
  python-reportbug python-reportlab-accel python-sip python-six python-xapian
  python-xdg python-zeitgeist python2.7 python2.7-minimal python3-aptdaemon
  python3-aptdaemon.gtk3widgets qdbus qpdf qt4-qtconfig qtchooser qtcore4-l10n
  rarian-compat readline-common rfkill rpcbind rpm rpm-common rpm2cpio rsync
  rtkit sed sgml-data shared-mime-info simple-scan solydx-info
  solydxk-flashplugin-11 solydxk-softwaremanager solydxk-system ssl-cert sudo
  synaptic system-config-printer system-config-printer-udev
  system-tools-backends t1utils tar tasksel tasksel-data tcpd tdb-tools
  texinfo thunar thunar-archive-plugin thunar-data thunar-volman time
  traceroute ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-freefont tumbler
  tumbler-common tzdata tzdata-java ucf udev ufw unattended-upgrades unrar
  unzip user-setup uuid-runtime vim-common vim-tiny w3m wdiff whiptail whois
  wireless-regdb wpasupplicant x11-apps x11-common x11-session-utils x11-utils
  x11-xfs-utils x11-xkb-utils x11-xserver-utils x11proto-core-dev
  x11proto-input-dev xarchiver xauth xdg-user-dirs xdg-utils xfburn
  xfce-keyboard-shortcuts xfce4-battery-plugin xfce4-cellmodem-plugin
  xfce4-clipman xfce4-clipman-plugin xfce4-datetime-plugin
  xfce4-diskperf-plugin xfce4-linelight-plugin xfce4-mailwatch-plugin
  xfce4-mixer xfce4-mount-plugin xfce4-mpc-plugin xfce4-notes
  xfce4-notes-plugin xfce4-notifyd xfce4-places-plugin
  xfce4-quicklauncher-plugin xfce4-screenshooter xfce4-terminal
  xfce4-timer-plugin xfce4-verve-plugin xfce4-volumed xfce4-wavelan-plugin
  xfce4-weather-plugin xfce4-wmdock-plugin xfconf xfonts-encodings
  xfonts-utils xfwm4 xinit xkb-data xscreensaver xscreensaver-data
  xserver-common xserver-xorg-input-all xterm xtrans-dev xz-utils yelp
  yelp-xsl zeitgeist zenity zenity-common zip
981 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 160 não atualizados.
É preciso baixar 0 B/471 MB de arquivos.
But it gave me this, below, even after rebooting, cleaning the cache and all:

Code: Select all

imagemagick (8:6.8.9.9-1) unstable; urgency=high

  Obsolete config scripts (Magick-config, MagickCore-config,
  MagickWand-config, Wand-config and Magick++-config) are
  not multi-arch safe and thus have been removed from /usr/bin.
  .
  Moreover, these scripts are superseded by pkg-config
  facilities.
  .
  However as a courtesy to our users, these scripts have
  been moved to
  /usr/lib/$DEB_HOST_MULTIARCH/ImageMagick-$VERSION/bin-$QUANTUMDEPTH/
  where $DEB_HOST_MULTIARCH is the multi-arch triplet and
  $QUANTUMDEPTH is the current quantum depth. $VERSION is the upstream
  version without the revision number.
  .
  Please note that these scripts will be definitively removed after
  jessie.

 -- Bastien Roucariès <roucaries.bastien+debian@gmail.com>  Sun, 19 Oct 2014 12:12:20 +0200

amd64-microcode (2.20141028.1) unstable; urgency=medium

    This release drops support for automatically applying microcode updates
    without a reboot.  The microcode updates can still be applied without a
    reboot through manual action of the system administrator.
:
I'll appreciate some help. Again: I'm trying to upgrade SX 32 bits home to Jessie.

Don't be a pirate, nor a slave. Use GNU/Linux!
GNU/Linux user 451206
SolydXK, GALPon MiniNo, PCLinuxOS, Xubuntu



User avatar
Arjen Balfoort
Site Admin
Posts: 9283
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Sources.list

Postby Arjen Balfoort » 05 May 2015 07:22

I moved your post to the "HE to Jessie upgrade" topic.

I assume you followed the steps that were indicated in the OP: http://forums.solydxk.nl/viewtopic.php?f=32&t=5095

After the first dist-upgrade and a reboot, did you run dist-upgrade again?

If not, please do so and post back the output here for any errors.


SolydXK needs you!
Development | Testing | Translations

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: HE to Jessie upgrade

Postby Zill » 05 May 2015 10:24

Gonzalo_VC: You might also like to remove packages from deb-multimedia.org as the current SolydXK ISOs have replaced these with packages directly from the Debian repos.

Grizzler has kindly produced a script for this (Remove deb-multimedia.org - dmo) which I have used and worked well for me but first you do need to check which multimedia packages you currently use to make sure you find suitable replacement(s). For example, ffmpeg has been replaced by avconf and this can cause problems in certain circumstances.

See http://forums.solydxk.nl/viewtopic.php? ... &start=100

User avatar
Gonzalo_VC
Posts: 321
Joined: 07 May 2013 13:25
Location: SouthAmerica

Re: HE to Jessie upgrade

Postby Gonzalo_VC » 05 May 2015 12:21

Thanks, guys, for I have a kind of broken / looping upgrade. Some packages take more than half an hour to install, and in the end, I keep receiving the message from my previous post. I'm planning of wiping the hard drive if I cannot resolve this :(

Don't be a pirate, nor a slave. Use GNU/Linux!
GNU/Linux user 451206
SolydXK, GALPon MiniNo, PCLinuxOS, Xubuntu



User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: HE to Jessie upgrade

Postby Zill » 05 May 2015 14:08

Gonzalo_VC: Just so we can see exactly what is going on would you please open a terminal and post the full output of the following three commands:

Code: Select all

inxi -r
LC_ALL=C sudo apt-get update
LC_ALL=C sudo apt-get dist-upgrade

jcsokolow
Posts: 1
Joined: 22 Sep 2015 23:44

Re: HE to Jessie upgrade

Postby jcsokolow » 22 Sep 2015 23:53

Hey All, I'm pretty late to this upgrade. I installed solydK about a year ago but I ended up letting the install languish. So it's still running mid 2014 packages. Anyway, I updated my apt sources.list and did an apt-get update but now I see...

Fetched 15.0 MB in 8s (1,815 kB/s)
Reading package lists... Done
W: There is no public key available for the following key IDs:
9D6D8F6BC857C906
W: There is no public key available for the following key IDs:
7638D0442B90D010
W: There is no public key available for the following key IDs:
7638D0442B90D010
NO_PUBKEY CBF8D6FD518E17E1

I have not begun the dist upgrade yet. Any help would be appreciated! Thanks!


So I solved this with the help of the interwebz.
Apply the select answer to each of the three keys above.
http://stackoverflow.com/questions/1139 ... -is-not-av

sudo su
apt-get install debian-keyring
gpg --keyserver pgp.mit.edu --recv-keys 9D6D8F6BC857C906
gpg --armor --export 9D6D8F6BC857C906 | apt-key add -
gpg --keyserver pgp.mit.edu --recv-keys 7638D0442B90D010
gpg --armor --export 7638D0442B90D010 | apt-key add -
gpg --keyserver pgp.mit.edu --recv-keys CBF8D6FD518E17E1
gpg --armor --export CBF8D6FD518E17E1 | apt-key add -
apt-get udpate

And all is well!


Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 3 guests