APT converting to SolydK

Questions specific to the KDE DE go here
josk
Posts: 33
Joined: 09 Mar 2013 19:16

APT converting to SolydK

Postby josk » 09 Mar 2013 19:38

Hi,

I installed about year ago LMDE XFCE edition and apt-get installed KDE to it. So I'm not running your Unofficial KDE up6 iso.

Usually after some Mint updates I have time to time some problems like default filemanager turns again to be Thunar and KDE's notification window look like notification window of XFCE. I'm running KDE and I don't want to see anything XFCE related on KDE. XFCE could be there as secondary system if I have some problems with KDE.

Now I don't want to reinstall my OS but convert it to be SolydK. Could you tell me what LMDE packages I should remove and what extra packages your default installation offers?

-josk

cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: APT converting to SolydK

Postby cwwgateway » 09 Mar 2013 19:53

Welcome to SolydXK :D

TBH, your setup is not particularly standard. You could try the tutorial here http://solydxk.com/community/tutorials/, but you have both Xfce and KDE installed, and that could be very problematic. If it helps at all, here's the output of sudo apt-get install solydk-meta on my machine (solydx):

Code: Select all

christopher@chris-laptop:~$ sudo apt-get install solydk-meta
[sudo] password for christopher: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  docbook-xsl kate-data katepart kde-runtime kde-runtime-data kde-wallpapers-default kde-workspace-kgreet-plugins kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdm kdoctools libattica0 libclucene0ldbl libdbusmenu-qt2 libdlrestrictions1 libiodbc2
  libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4
  libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkworkspace4abi1 libnepomuk4 libnepomukquery4a libnepomukutils4
  libnl-route-3-200 libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1 libqca2 libqimageblitz4 libqt4-qt3support
  libsolid4 libsoprano4 libssh-4 libstreamanalyzer0 libstreams0 libthreadweaver4 libvirtodbc0 libxml2-utils ntrack-module-libnl-0
  phonon phonon-backend-vlc plasma-scriptengine-javascript plymouth-themes-solydk shared-desktop-ontologies solydk-artwork
  solydk-grub2-theme solydk-info solydk-system-adjustments soprano-daemon virtuoso-minimal virtuoso-opensource-6.1-bin
  virtuoso-opensource-6.1-common
Suggested packages:
  docbook-xsl-doc-html docbook-xsl-doc-pdf docbook-xsl-doc-text docbook-xsl-doc libsaxon-java libxalan2-java libxslthl-java
  docbook-xsl-saxon fop xalan dbtoepub djvulibre-bin finger kdepasswd kde-wallpapers hspell libqca2-plugin-cyrus-sasl
  libqca2-plugin-gnupg libqca2-plugin-ossl media-player-info phonon-backend-gstreamer phonon-backend-mplayer
The following NEW packages will be installed:
  docbook-xsl kate-data katepart kde-runtime kde-runtime-data kde-wallpapers-default kde-workspace-kgreet-plugins kdelibs-bin
  kdelibs5-data kdelibs5-plugins kdm kdoctools libattica0 libclucene0ldbl libdbusmenu-qt2 libdlrestrictions1 libiodbc2
  libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4
  libkemoticons4 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4
  libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libkworkspace4abi1 libnepomuk4 libnepomukquery4a libnepomukutils4
  libnl-route-3-200 libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1 libqca2 libqimageblitz4 libqt4-qt3support
  libsolid4 libsoprano4 libssh-4 libstreamanalyzer0 libstreams0 libthreadweaver4 libvirtodbc0 libxml2-utils ntrack-module-libnl-0
  phonon phonon-backend-vlc plasma-scriptengine-javascript plymouth-themes-solydk shared-desktop-ontologies solydk-artwork
  solydk-grub2-theme solydk-info solydk-meta solydk-system-adjustments soprano-daemon virtuoso-minimal virtuoso-opensource-6.1-bin
  virtuoso-opensource-6.1-common
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

josk
Posts: 33
Joined: 09 Mar 2013 19:16

Re: APT converting to SolydK

Postby josk » 10 Mar 2013 13:43

cwwgateway wrote:If it helps at all, here's the output of sudo apt-get install solydk-meta on my machine (solydx):
That helped! Installing that solydk-meta package removed almost every mint-related packages. I just needed manually remove two mint related packages that are not needed anymore. Everything works now like it should be!

Main reasons to convert SolydK were:

1. Up-to-date extra packages like Firefox etc..
2. In LMDE there was only about 3 update packages in year. If I am correct your are going to release update packages / snapshots in monthly basis. I like to balancing in stability and still use rolling distro. So semi-rolling distro would be best for me. I have tried pure testing and sid.
3. It's Debian

So now I have still couple questions about SolydK default functionality to get familiar with it.

1) Is pulseaudio installed by default? I have always removed that one and used pure ALSA. Works much better that way!

2) About update packages (ex. upcoming up7). Are you really planning to do updates monthly? I hope so. Are you taking base of those snapshots from Debian repository / LMDE repository / Debian-CUT repository? I understand that you will offer some extra packages over the base snapshots like up-to-date Firefox.

3) Could you think to add some third party packages or repositories from trusted source to your distro? If yes, then here comes my hot list of things that I always use on my debian system.

- Spotify: deb http://repository.spotify.com stable non-free
- More up-to-date version of Clementine from it's website that contains Spotify integration. Debian repository version doesn't contain Spotify online service.
- IconTasks http://kde-apps.org/content/show.php/?content=144808
- SMXI http://smxi.org/
- Periscope subtitle search engine with Dolphin integration,I could help with Dolphin integration if needed. http://code.google.com/p/periscope/
- Submarine subtitle search engine with Dolphin integration, I could help with Dolphin integration if needed. https://github.com/blazt/submarine

If you could accept some of those to be part of your distro it would be great!

-josk

User avatar
Arjen Balfoort
Site Admin
Posts: 9377
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: APT converting to SolydK

Postby Arjen Balfoort » 10 Mar 2013 15:53

josk wrote:That helped! Installing that solydk-meta package removed almost every mint-related packages. I just needed manually remove two mint related packages that are not needed anymore. Everything works now like it should be!
I'm glad it worked. It means that more users get make the conversion then only those with the unofficial LMDE KDE / Xfce.
josk wrote:1) Is pulseaudio installed by default? I have always removed that one and used pure ALSA. Works much better that way!
It's default because it simplifies audio configuration for the majority of people.
josk wrote:2) About update packages (ex. upcoming up7). Are you really planning to do updates monthly? I hope so. Are you taking base of those snapshots from Debian repository / LMDE repository / Debian-CUT repository? I understand that you will offer some extra packages over the base snapshots like up-to-date Firefox.
http://forums.solydxk.nl/viewtopic.php?f=17&t=152
josk wrote:3) Could you think to add some third party packages or repositories from trusted source to your distro? If yes, then here comes my hot list of things that I always use on my debian system.
Please post your suggestions here: http://forums.solydxk.nl/viewforum.php?f=14


SolydXK needs you!
Development | Testing | Translations


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 1 guest