[SOLVED] Installation on existing md raids

Questions about SolydX and SolydK installation.
Posts: 362
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

[SOLVED] Installation on existing md raids

Postby SolydForEver » 30 Apr 2016 04:41


At the moment I use as my main system LinuxMint 17.3 KDE-64. I have it installed on 5 raid devices:
md2 = root
md3 = swap
md4 = home
md11 = Data
md12 = Music

plus 1 normal partition sda1 = boot

I am now trying to install SolydK on these raids. What I do in the live version is this:

Code: Select all

su -
apt update
apt install mdadm

mdadm --assemble /dev/md2
mdadm --assemble /dev/md3
mdadm --assemble /dev/md4
mdadm --assemble /dev/md11
mdadm --assemble /dev/md12

mkdir /target
cd /target
mkdir boot
mkdir home
mkdir Data
mkdir Music

mount /dev/md2 /target
mount /dev/md4 /target/home
mount /dev/md11 /target/Data
mount /dev/md12 /target/Music
When I type

Code: Select all

I see:

Code: Select all

boot Data home Music
In other words it looks as if the raid's are empty, which they are not.
When I start GParted I see my md's and I also see they are partially filled with my data from the LinuxMint installation, which by the way is still fully operational. I checked it by booting into Mint again.

What am I doing wrong here? Or am I expecting something which is never going to happen?
I assemble the raids, I mount them and still I don't see the contents of them.
The idea of course is to keep my data on the /Data and /Music folder. I have backups so I could start from scratch but this just has to work, right?

[EDIT] I don't know what I did differently but suddenly it started to install, although I must say I now have empty raids. But as written I do have a solid backup which is busy right now to restore my data. Thank you for reading my post.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 8 guests