[solved] Copy Paste Garbage "00~text01~"

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

[solved] Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 10:34

Hi,
I have this old Bug und my system: https://bugs.launchpad.net/ubuntu/+sour ... ug/1350334

- copy : text
- paste
- get this: "00~text01~"

How can I / we fix this in the CE ?
Thanks :)
Image
SolydX 10 64 - Debian Buster

User avatar
ilu
Posts: 2295
Joined: 09 Oct 2013 12:45

Re: Copy Paste Garbage "00~text01~"

Postby ilu » 03 Sep 2016 11:05

I understand there's a problem copy-pasting something to/from mc and terminator. It would be nice if you included a short description of your problem instead of just linking to a lengthy bug report. Also the output of "inxi -Fxzr" would tell everybody which system you are on.

I read the bug report anyway and somebody there said the problem is fixed in debian. Several others said it's not going to be fixed at all. Whatever the truth is, since this is a bug upstream what do you expect us to do about it?

I might have misunderstood your problem though.

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 12:25

I tested now again. My mistake. Its not in mc.

I have this issue in ssh sessions. When I open a ssh to a ubuntu or to an OpenBSD or a FreeBSD. I copy f.e. in my Firefox and paste into the session.

So I get this garbage. But not in local mc. Also in the remote mc. But in all paste's in the remote computer.
Edit: also when I copy in ssh session and paste again in the ssh session. When I copied "init-Fxzr" from Firefox and pasted into terminal, I got the same issue. Crazy.

Code: Select all

#inxi -Fxzr
System:    Host: br4nd0 Kernel: 4.6.0-1-amd64 x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: SolydXK
Machine:   Mobo: MSI model: 990FXA-GD80 (MS-7640) v: 2.2
           Bios: American Megatrends v: V13.5 date: 09/17/2013
CPU:       Quad core AMD FX-8320 Eight-Core (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 28003
           clock speeds: max: 3500 MHz 1: 1700 MHz 2: 1400 MHz 3: 1400 MHz
           4: 1400 MHz 5: 1400 MHz 6: 1400 MHz 7: 2900 MHz 8: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Park [Mobility Radeon HD 5430]
           bus-ID: 05:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD CEDAR (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.2 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series]
           driver: snd_hda_intel bus-ID: 05:00.1
           Sound: Advanced Linux Sound Architecture v: k4.6.0-1-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1250.3GB (9.0% used)
           ID-1: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB temp: 38C
           ID-2: /dev/sda model: Samsung_SSD_840 size: 250.1GB temp: 0C
Partition: ID-1: / size: 25G used: 9.3G (41%) fs: ext4 dev: /dev/dm-2
           ID-2: /boot size: 465M used: 96M (22%) fs: ext4 dev: /dev/sda1
           ID-3: /home size: 201G used: 44G (23%) fs: ext4 dev: /dev/dm-3
           ID-4: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 23.4C mobo: 127.0C gpu: 62.5
           Fan Speeds (in rpm): cpu: 2347 fan-2: 0 fan-3: 0
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://repository.solydxk.com solydxk main upstream import
           deb http://ftp.de.debian.org/debian testing main contrib non-free
           deb http://security.debian.org testing/updates main contrib non-free
           deb http://ppa.launchpad.net/numix/ppa/ubuntu xenial main
Info:      Processes: 258 Uptime: 45 min Memory: 1149.4/11968.3MB
           Init: systemd runlevel: 5 Gcc sys: 6.1.1
           Client: Shell (bash 4.3.461) inxi: 2.3.0 
Image
SolydX 10 64 - Debian Buster

User avatar
ilu
Posts: 2295
Joined: 09 Oct 2013 12:45

Re: Copy Paste Garbage "00~text01~"

Postby ilu » 03 Sep 2016 13:16

What terminal did you use in your ssh sessions? Did you try a different terminal? SolydX should have xfce4-terminal and xterm installed.

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 13:17

xfce4-terminal 0.6.3

Now my first try with xterm: no issue
but the xterm ist non comfortable^^

Alternatives?
Image
SolydX 10 64 - Debian Buster

User avatar
ilu
Posts: 2295
Joined: 09 Oct 2013 12:45

Re: Copy Paste Garbage "00~text01~"

Postby ilu » 03 Sep 2016 13:24

I can't reproduce the error. Not with or without MC running on the remote. I'm not on EE but I use the same XFCE terminal version 0.6.3. My remotes are running debian though so I can't comment on any remote running 'buntu.

I've never used any other terminals but maybe somebody else can recommend one.

Maybe have a look at your XFCE-Terminal settings. Compatibility on mine is set to "xterm". Character encoding is set to UTF-8.

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 13:27

The behavier is crazy. I still have ever the issue, when I'm or I was ssh to OpenBSD (my Web- and Mail-Server).
Image
SolydX 10 64 - Debian Buster

User avatar
ilu
Posts: 2295
Joined: 09 Oct 2013 12:45

Re: Copy Paste Garbage "00~text01~"

Postby ilu » 03 Sep 2016 13:30

Have a look at my last post again, I added something.

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 13:35

I have the same settings.

try this please:

ssh to serverxyz (if possible OpenSSH)
mc
close mc
paste

local:
mc
close mc
paste

Then I always have the issue.

I should try any other terminal emulator.
Image
SolydX 10 64 - Debian Buster

User avatar
ilu
Posts: 2295
Joined: 09 Oct 2013 12:45

Re: Copy Paste Garbage "00~text01~"

Postby ilu » 03 Sep 2016 13:40

No sorry, works for me. It might have something to do with the remote system.

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 13:44

Hm, its not only one remote System :/

1. OpenBSD
2. Ubuntu on AWS EC2
3. also my local maschine (mc, close, paste)

tried Terminator -> same issue
xterm -> no issue, but small font size, ugly userbility

I will trie to find out more Infos. Thank you for you time.
Image
SolydX 10 64 - Debian Buster

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 13:49

installed gnome-terminal

-> no issue
Image
SolydX 10 64 - Debian Buster

User avatar
ilu
Posts: 2295
Joined: 09 Oct 2013 12:45

Re: Copy Paste Garbage "00~text01~"

Postby ilu » 03 Sep 2016 14:39

I'm glad you found a working terminal. Please edit your first post and mark it as [solved].

User avatar
mil3s
Posts: 52
Joined: 13 Aug 2014 13:22

Re: [solved] Copy Paste Garbage "00~text01~"

Postby mil3s » 03 Sep 2016 14:55

Done. BTW Konsole (KDE) also works great. But is much more overhead.
Image
SolydX 10 64 - Debian Buster


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 0 guests