Breakage and News tracker for debian testing [buster]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
grizzler
Posts: 2035
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakage and News tracker for debian testing [buster]

Postby grizzler » 08 Jul 2018 16:03

Potential systemd/udev upgrading problems:
https://bugs.debian.org/cgi-bin/bugrepo ... bug=903224
https://bugs.debian.org/cgi-bin/bugrepo ... bug=902185

I'm not in the mood for more computer related issues, so I've put both systemd and udev on hold for now.
Frank

SolydX EE 64 - tracking Debian Testing

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 09 Jul 2018 04:37

thanks for the report :3

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 22 Jul 2018 12:22

new systemd has arrived. it should fix the breakage earlier.

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 23 Jul 2018 06:26

today we got new kernel but I saw this message during the upgrade process :

Code: Select all

Setting up linux-headers-4.17.0-1-amd64 (4.17.8-1) ...
/etc/kernel/header_postinst.d/dkms:
Error! Bad return status for module build on kernel: 4.17.0-1-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.10/build/make.log for more information.
the kernel boot up succesfully. virtualbox is obviously broken. aside form that I also got lot of these error messages

Code: Select all

pstore: crypto_comp_decompress failed, ret = -22!
the bug report said it was relatively easy to remove these messages but I'll keep open this issue until debian fixed it.
https://bugs.debian.org/cgi-bin/bugrepo ... bug=902966
method to remove it
https://myn.meganecco.org/1524119100.html
unfortunately it's on japanese.

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 23 Jul 2018 10:52

Je suis en vacances et le PC portable avec SolydX EE 64 est resté chez moi je verrai ça à mon retour...J'espère que le système restera fonctionnel et il n'y a pas de téléchargement disponible...

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 23 Jul 2018 13:04

virtualbox is the only thing noticeably broken by this update. I think most of us didn't affected by this issue. though, it means another delay for the EE iso development. this issue seems have been reported during the kernel RC stage so I hope it will be fixed soon.

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 23 Jul 2018 19:36

Serait-il imprudent dans 15 jours de faire une mise à jour !!!??? Quelle est la meilleure position à adopter dans le cas présent.

Deleted User 2781

Re: Breakage and News tracker for debian testing [buster]

Postby Deleted User 2781 » 24 Jul 2018 20:32

Thanks for reports. :)

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 24 Jul 2018 21:55

virtualbox issue is now fixed.
@san-claudio: if you're not using virtualbox you can upgrade it safely. there's still the glitch in the kernel as I mentioned earlier but it doesn't affect either our system functionality nor stability. you also still has the old kernel so it doesn't really matter.

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 26 Aug 2018 04:08

pulseaudio is broken. I've got some news from here https://bbs.archlinux.org/viewtopic.php?id=238251 but haven't fixed my system yet. if anyone have alternative or better solution please let me know.

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 26 Aug 2018 14:14

J'ai eu quelque chose ce jour sur pulseaudio et config des paquets en problème de dépendance de version en faisant la mise à jour par 'sudo aptitude full-upgrade' qui m'a proposé une solution en deux points auquel j'ai répondu Yes...
Mais je dois toujours faire au terminal 'systemctl stop timidity' et suivi de 'pulseaudio -k' pour avoir du son...
Je me demande si sur la nouvelle version de SolydX EE il faut se trainer ce problème...

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 27 Aug 2018 00:35

in my case, pulseaudio is still working but it can't load any ladspa modules anymore. most of user might not notice this issue since most of them didn't use the modules.

btw, to avoid problem it might be better to always run "dist-upgrade" instead of other upgrade command. "dist-upgrade" algorythm works better for EE user.

User avatar
grizzler
Posts: 2035
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakage and News tracker for debian testing [buster]

Postby grizzler » 27 Aug 2018 10:44

That's a given. Never use plain upgrade on a Testing based setup. Always dist-upgrade/full-upgrade.

W.r.t. the timidity issue: there was something about that package not so long ago: https://forums.solydxk.com/viewtopic.php?f=78&t=7292

The problem mentioned in https://bugs.debian.org/cgi-bin/bugrepo ... bug=901148 was supposedly fixed, but later reports indicate there's still an issue.

I suggest people who don't use midi remove timidity.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 27 Aug 2018 11:30

Effectivement j'ai supprimé le paquet timitidy et j'ai retrouvé le son sans faire de commande au terminal.
Attachments
maj 20180827.txt
(922 Bytes) Downloaded 3 times

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 04 Sep 2018 00:49

this morning the update give this message

Code: Select all

Installing for x86_64-efi platform.
Could not prepare Boot variable: No space left on device
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.
I fixed it by running

Code: Select all

sudo rm /sys/firmware/efi/efivars/dump-*
#followed by
sudo update-grub
sudo grub-install

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 04 Sep 2018 11:29

Je n'ai pas eu ça, mais il y avait beaucoup de firmware en mise à jour : c'est la première fois que j'en vois autant d'un seul coup.

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 16 Sep 2018 12:49

J'ai le noyau 4.18.0-1 depuis la semaine dernière par les mises à jour... Mais je reste toujours sur le noyau 4.16 alors que 4.17 est aussi installé... Les images sont bien dans Synaptic... Auparavant le dernier noyau mise à jour était pris en compte et le nettoyage par autoremove des anciens noyaux était effectué. Au boot dans Options avancées s'affiche que 4.16.
Attachments
kernel.txt
(1.5 KiB) Downloaded 4 times

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 17 Sep 2018 00:20

can you please run these command and tell us the result?

Code: Select all

uname -a
dpkg -l |grep linux

User avatar
san-claudio
Posts: 208
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakage and News tracker for debian testing [buster]

Postby san-claudio » 17 Sep 2018 10:55

Code: Select all

san-claudio@solydxk:~$ uname -a
Linux solydxk 4.16.0-2-amd64 #1 SMP Debian 4.16.16-2 (2018-06-22) x86_64 GNU/Linux
san-claudio@solydxk:~$ dpkg -l |grep linux
ii  binutils-x86-64-linux-gnu                                   2.31.1-5                                                  amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                                         1.185                                                     all          Linux specific part of console-setup
ii  extlinux                                                    3:6.04~git20171011.af7e95c3+dfsg1-4                       amd64        collection of bootloaders (Linux ext2/ext3/ext4, btrfs, and xfs bootloader)
ii  firmware-linux                                              20180825+dfsg-1                                           all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  firmware-linux-free                                         3.4                                                       all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                                      20180825+dfsg-1                                           all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  fonts-linuxlibertine                                        5.3.0-4                                                   all          Linux Libertine family of fonts
ii  libselinux1:amd64                                           2.8-1+b1                                                  amd64        SELinux runtime shared libraries
ii  libselinux1:i386                                            2.8-1+b1                                                  i386         SELinux runtime shared libraries
ii  libv4l-0:amd64                                              1.14.2-1                                                  amd64        Collection of video4linux support libraries
ii  libv4l-0:i386                                               1.14.2-1                                                  i386         Collection of video4linux support libraries
ii  libv4lconvert0:amd64                                        1.14.2-1                                                  amd64        Video4linux frame format conversion library
ii  libv4lconvert0:i386                                         1.14.2-1                                                  i386         Video4linux frame format conversion library
ii  linux-base                                                  4.5                                                       all          Linux image base package
ii  linux-compiler-gcc-7-x86                                    4.18.6-1                                                  amd64        Compiler for Linux on x86 (meta-package)
ii  linux-doc-4.16                                              4.16.16-2                                                 all          Linux kernel specific documentation for version 4.16
ii  linux-headers-4.16.0-2-amd64                                4.16.16-2                                                 amd64        Header files for Linux 4.16.0-2-amd64
ii  linux-headers-4.16.0-2-common                               4.16.16-2                                                 all          Common header files for Linux 4.16.0-2
ii  linux-headers-4.17.0-3-amd64                                4.17.17-1                                                 amd64        Header files for Linux 4.17.0-3-amd64
ii  linux-headers-4.17.0-3-common                               4.17.17-1                                                 all          Common header files for Linux 4.17.0-3
ii  linux-headers-4.18.0-1-amd64                                4.18.6-1                                                  amd64        Header files for Linux 4.18.0-1-amd64
ii  linux-headers-4.18.0-1-common                               4.18.6-1                                                  all          Common header files for Linux 4.18.0-1
ii  linux-headers-amd64                                         4.18+98                                                   amd64        Header files for Linux amd64 configuration (meta-package)
rc  linux-image-4.15.0-3-amd64                                  4.15.17-1                                                 amd64        Linux 4.15 for 64-bit PCs
rc  linux-image-4.16.0-1-amd64                                  4.16.5-1                                                  amd64        Linux 4.16 for 64-bit PCs
ii  linux-image-4.16.0-2-amd64                                  4.16.16-2                                                 amd64        Linux 4.16 for 64-bit PCs
rc  linux-image-4.17.0-1-amd64                                  4.17.8-1                                                  amd64        Linux 4.17 for 64-bit PCs
ii  linux-image-4.17.0-3-amd64                                  4.17.17-1                                                 amd64        Linux 4.17 for 64-bit PCs
ii  linux-image-4.18.0-1-amd64                                  4.18.6-1                                                  amd64        Linux 4.18 for 64-bit PCs
pc  linux-image-4.6.0-1-amd64                                   4.6.4-1                                                   amd64        Linux 4.6 for 64-bit PCs
ii  linux-kbuild-4.16                                           4.16.16-2                                                 amd64        Kbuild infrastructure for Linux 4.16
ii  linux-kbuild-4.17                                           4.17.17-1                                                 amd64        Kbuild infrastructure for Linux 4.17
ii  linux-kbuild-4.18                                           4.18.6-1                                                  amd64        Kbuild infrastructure for Linux 4.18
ii  linux-libc-dev:amd64                                        4.18.6-1                                                  amd64        Linux support headers for userspace development
ii  pptp-linux                                                  1.9.0+ds-2                                                amd64        Point-to-Point Tunneling Protocol (PPTP) Client
ii  skypeforlinux                                               8.30.0.50                                                 amd64        Skype keeps the world talking, for free.
ii  syslinux                                                    3:6.04~git20171011.af7e95c3+dfsg1-4                       amd64        collection of bootloaders (DOS FAT and NTFS bootloader)
ii  syslinux-common                                             3:6.04~git20171011.af7e95c3+dfsg1-4                       all          collection of bootloaders (common)
ii  util-linux                                                  2.32.1-0.1                                                amd64        miscellaneous system utilities
san-claudio@solydxk:~$ 

kurotsugi
Posts: 2092
Joined: 09 Jan 2014 00:17

Re: Breakage and News tracker for debian testing [buster]

Postby kurotsugi » 18 Sep 2018 06:48

all the packages are there. I'm not quite sure why the other kernel won't show up.

Code: Select all

sudo update-initramfs -u 
sudo update-grub
lets try with these ones. please run these command and tell us the result.


Return to “Testing zone”

Who is online

Users browsing this forum: No registered users and 0 guests