SOLVED: "Recovery Mode" Bootup Hangs after Loading Bluetooth/HCI0 module

Questions specific to the KDE DE go here
Posts: 1
Joined: 14 Dec 2017 01:00

SOLVED: "Recovery Mode" Bootup Hangs after Loading Bluetooth/HCI0 module

Postby SolydKUser » 14 Dec 2017 01:19

AS AT NOV 2017:

I have recently installed SolydK 9.6, including the online updates at the end of the process.

The Console Mode bootup almost gets to the point where you would see a Command Line prompt, but instead seems to hang at this point:
"Bluetooth: BNEP socket layer initialized"

When I boot in normal mode and run dmesg, in Konsole, it shows about 12 final steps after this one, so it looks like it's a fairly minor glitch.

Maybe an error in the online updates?

Note bluetooth as such seems to run fine when in normal mode in terms of pairing headphones etc.



I'm not sure if it is actually kde-specific, but SolydK 9 doesn't seem to allow logging in as non-root user when booting in Recovery Mode. In Recovery Mode there is a prompt to log in as root after bootup, IF AUTOLOGIN IS DISABLED.
In other words, autologin now has to be disabled to use Recovery Mode, and run outside of X.
For some reason the "LightDM GTK + Greeter Settings" "front-end" no longer seems to have the feature for this.
It can be done by manually editing /etc/lightdm/lightdm.conf, and commenting out:
See: See: ... ebian.html

Technical Note:

The relevant error seems to be reported in /var/log/messages as:
"udev-acl[2022]: g_slice_set_config: assertion 'sys_page_size == 0' failed"
See ... 00774.html

A few Recovery Mode "console session" tips:
- To get the desktop again, you can type "exit" to conclude the "console session" and then login via the splash screen as a normal desktop user.
- You can also type "startx" as root if you want the desktop as root for some reason.

Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 3 guests