SolydXK System Settings freezes [SOLVED]

Questions about SolydX and SolydK installation.
User avatar
amnesix
Posts: 176
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

SolydXK System Settings freezes [SOLVED]

Postby amnesix » 15 May 2019 13:45

Hi there !

Since I just bought a new machine, I got to re-install SolydX, with the 20191902 iso, through a USB stick.

I wanted to use SolydXK System Settings, but the program freezes : I see the transitional screen, and it remains so.

I looked at the used processes (with the Task Manager), and saw a «hung» process : «hwinfo --framebuffer». As soon as kill the process, the program starts, and I can, for instance, choose the server for my debian repository.

My machine :

Code: Select all

$ inxi -Fxz
System:    Host: bigleon Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: SolydXK
Machine:   Device: desktop Mobo: ASUSTeK model: PRIME B450M-A v: Rev X.0x
           UEFI [Legacy]: American Megatrends v: 1002 date: 03/07/2019
CPU:       Octa core AMD Ryzen 7 1700X Eight-Core (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 54292
           clock speeds: max: 3400 MHz 1: 2200 MHz 2: 2200 MHz 3: 2200 MHz
           4: 2200 MHz 5: 2200 MHz 6: 2200 MHz 7: 2200 MHz 8: 2200 MHz
           9: 2200 MHz 10: 2200 MHz 11: 2200 MHz 12: 2200 MHz 13: 2200 MHz
           14: 2200 MHz 15: 2200 MHz 16: 2200 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480]
           bus-ID: 08:00.0
           Display Server: X.Org 1.19.2 drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD POLARIS10 (DRM 3.8.0 / 4.9.0-9-amd64, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 1457
           driver: snd_hda_intel bus-ID: 0a:00.3
           Card-2 Advanced Micro Devices [AMD/ATI] Device aaf0
           driver: snd_hda_intel bus-ID: 08:00.1
           Sound: Advanced Linux Sound Architecture v: k4.9.0-9-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: f000 bus-ID: 07:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 6497.3GB (6.6% used)
           ID-1: /dev/sda model: Patriot_Burst size: 480.1GB
           ID-2: /dev/sdc model: ST2000DM008 size: 2000.4GB
           Partition: ID-1: / size: 16G used: 7.6G (51%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 392G used: 358G (97%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 34.36GB used: 0.00GB (0%) fs: swap dev: /dev/sda1
Sensors:   System Temperatures: cpu: N/A mobo: N/A gpu: 30.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 313 Uptime: 20 min Memory: 1329.1/32177.1MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.121) inxi: 2.3.5 

User avatar
Arjen Balfoort
Site Admin
Posts: 9282
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: SolydXK System Settings freezes

Postby Arjen Balfoort » 15 May 2019 14:07

What is the output of:

Code: Select all

sudo hwinfo --framebuffer | awk '{print $3}' | egrep '[0-9]+x[0-9]+$' | uniq


SolydXK needs you!
Development | Testing | Translations

User avatar
amnesix
Posts: 176
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: SolydXK System Settings freezes

Postby amnesix » 15 May 2019 15:44

I can't answer that question : hwinfo --framebuffer, as I wrote earlier, freezes. Or maybe «hangs». I've launched the command now 6 minutes ago, and I don't have an answer. The taskmanager shows the process, it takes about 6% of CPU, and stays there. I see on the CPU graph from the panel that it switches from one core the another, but no answer. Now 8 minutes. I'll kill it now. ;(

User avatar
Arjen Balfoort
Site Admin
Posts: 9282
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: SolydXK System Settings freezes

Postby Arjen Balfoort » 15 May 2019 18:44

I've uploaded a new version of solydxk-system to testing.
You can also download it directly: https://repository.solydxk.com/pool/tes ... .0_all.deb

I cannot test your issue but I've added a timeout of 5 seconds to the hwinfo process. In theory, this should end the process after 5 seconds and continue with the rest of the code.

Let me know if this works.


SolydXK needs you!
Development | Testing | Translations

User avatar
amnesix
Posts: 176
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: SolydXK System Settings freezes

Postby amnesix » 15 May 2019 18:59

Nope, hwinfo is staying hanging from the first second. Sorry.

User avatar
ilu
Posts: 2493
Joined: 09 Oct 2013 12:45

Re: SolydXK System Settings freezes

Postby ilu » 15 May 2019 19:41

Arjen Balfoort wrote:
15 May 2019 14:07

Code: Select all

sudo hwinfo --framebuffer | awk '{print $3}' | egrep '[0-9]+x[0-9]+$' | uniq
Actually, this command freezes for me too. But SolydXK System Settings works and I can't see it calling hwinfo.
On second try, the command runs fine. :o When I last tested solydxk-system I already noticed strange first-run-after-boot-results. So better just ignore my input.

User avatar
amnesix
Posts: 176
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

Re: SolydXK System Settings freezes

Postby amnesix » 16 May 2019 08:04

Problem definitely related to my hardware not recognized by the current version of hwinfo and/or inxi. I installed «ee», and the symptom disappeared.

Thank you !


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 0 guests