[Solved]Lightdm does not show new users

Questions about software.
User avatar
escolar
Posts: 132
Joined: 23 Aug 2013 08:14
Location: Spain

[Solved]Lightdm does not show new users

Postby escolar » 12 Sep 2019 20:19

I had only one user in my SolydK system. LightDM shown it with complete name and I only had to write the password. Today I have add 3 new users, but LightDM still only shows my complete name, and to enter in other user session they have to write username and password.

My etc/lightdm/lightdm.conf file has

Code: Select all

greeter-show-manual-login=false
Any idea about how to show all users in LighDM?

User avatar
ilu
Posts: 2477
Joined: 09 Oct 2013 12:45

Re: Lightdm does not show new users

Postby ilu » 12 Sep 2019 23:46

escolar wrote:
12 Sep 2019 20:19
My etc/lightdm/lightdm.conf file has

Code: Select all

greeter-show-manual-login=false
That's not the default setting. Please attach your /etc/lightdm/lightdm.conf file. There's also /usr/share/lightdm/lightdm.conf.d/ which might hold conflicting settings. I'm not sure which one takes precedence.

Are you on SolydK9 or SolydK10?

User avatar
escolar
Posts: 132
Joined: 23 Aug 2013 08:14
Location: Spain

Re: Lightdm does not show new users

Postby escolar » 13 Sep 2019 05:25

I'm in SolydK 10 (I recently updated from SolydK 9 using the Arjen's script)

This is my /etc/lightdm/lightdm.conf file:

Code: Select all

#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# logind-load-seats = True to automatically set up multi-seat configuration from logind
# logind-check-graphical = True to on start seats that are marked as graphical by logind
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# sessions-directory = Directory to find sessions
# remote-sessions-directory = Directory to find remote sessions
# greeters-directory = Directory to find greeters
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#logind-load-seats=false
#logind-check-graphical=false
#log-directory=/var/log/lightdm
#run-directory=/var/run/lightdm
#cache-directory=/var/cache/lightdm
#sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#greeters-directory=/usr/share/lightdm/greeters:/usr/share/xgreeters

#
# Seat defaults
#
# type = Seat type (xlocal, xremote)
# xdg-seat = Seat name to set pam_systemd XDG_SEAT variable and name to pass to X server
# pam-service = PAM service to use for login
# pam-autologin-service = PAM service to use for autologin
# pam-greeter-service = PAM service to use for greeters
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xserver-layout = Layout to pass to X server
# xserver-config = Config file to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xserver-share = True if the X server is shared for both greeter and session
# xserver-hostname = Hostname of X server (only for type=xremote)
# xserver-display-number = Display number of X server (only for type=xremote)
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# unity-compositor-command = Unity compositor command to run (can also contain arguments e.g. unity-system-compositor -special-option)
# unity-compositor-timeout = Number of seconds to wait for compositor to start
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# greeter-show-remote-login = True if the greeter should offer a remote login option
# user-session = Session to load for users
# allow-user-switching = True if allowed to switch users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# greeter-wrapper = Wrapper script to run greeter with
# guest-wrapper = Wrapper script to run guest sessions with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# display-stopped-script = Script to run after stopping the display server (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# autologin-in-background = True if autologin session should not be immediately activated
# exit-on-failure = True if the daemon should exit if this seat fails
#
[SeatDefaults]
#type=xlocal
#xdg-seat=seat0
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-command=X
#xserver-layout=
#xserver-config=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
#greeter-session=example-gtk-gnome
greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
#user-session=default
allow-user-switching=true
allow-guest=true
#guest-session=
#session-wrapper=lightdm-session
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=UNIMPLEMENTED
#exit-on-failure=false

#
# Seat configuration
#
# Each seat must start with "Seat:".
# Uses settings from [SeatDefaults], any of these can be overriden by setting them in this section.
#
#[Seat:0]

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#key=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#width=1024
#height=768
#depth=8
This is /usr/share/lightdm/lightdm.conf.d/01_debian.conf:

Code: Select all

# Debian specific defaults
#
# - use lightdm-greeter session greeter, points to the etc-alternatives managed
# greeter
# - hide users list by default, we don't want to expose them
# - use Debian specific session wrapper, to gain support for
# /etc/X11/Xsession.d scripts

[Seat:*]
greeter-session=lightdm-greeter
greeter-hide-users=true
session-wrapper=/etc/X11/Xsession
This is /usr/share/lightdm/ligthdm.conf.d/40-kde-plasma-kf5.conf:

Code: Select all

[SeatDefaults]
user-session=kde-plasma-kf5

User avatar
ilu
Posts: 2477
Joined: 09 Oct 2013 12:45

Re: Lightdm does not show new users

Postby ilu » 13 Sep 2019 13:14

I can't find any place in your config setting "greeter-show-manual-login=false". Doesn't matter.

/usr/share/lightdm/lightdm.conf.d/01_debian.conf has "greeter-hide-users=true" while /etc/lightdm has "greeter-hide-users=false" - I can't find out which one wins. Try to set both to false.

Best practice: Follow the explanation here: https://wiki.debian.org/LightDM#Enable_user_list

User avatar
escolar
Posts: 132
Joined: 23 Aug 2013 08:14
Location: Spain

Re: Lightdm does not show new users

Postby escolar » 13 Sep 2019 14:18

Thanks for your answer.

I am not at home during weekend, but I tried your suggestions next Monday

User avatar
escolar
Posts: 132
Joined: 23 Aug 2013 08:14
Location: Spain

Re: Lightdm does not show new users

Postby escolar » 16 Sep 2019 14:17

ilu wrote:
13 Sep 2019 13:14
usr/share/lightdm/lightdm.conf.d/01_debian.conf has "greeter-hide-users=true" while /etc/lightdm has "greeter-hide-users=false" - I can't find out which one wins. Try to set both to false.

Best practice: Follow the explanation here: https://wiki.debian.org/LightDM#Enable_user_list
I changed the option greeter-hide-users to FALSE in /usr/share/lightdm/lightdm.conf.d/01_debian.conf but it doesn't work. the strange thing is that I have a list with my user and "Other users". If another user want to login she/he have to write username and password. If I set to TRUE greeter-hide-users then I have to write my username too (that is, the option changes the behavior of the greater, but not to a all users list)

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Lightdm does not show new users

Postby Arjen Balfoort » 16 Sep 2019 14:26

I have only these enabled in /etc/lightdm/lightdm.conf:

Code: Select all

[SeatDefaults]
greeter-hide-users=false
allow-user-switching=true
session-wrapper=/etc/lightdm/Xsession
You have the first two also, but you're missing the session-wrapper.
Maybe that helps.


SolydXK needs you!
Development | Testing | Translations

User avatar
escolar
Posts: 132
Joined: 23 Aug 2013 08:14
Location: Spain

Re: Lightdm does not show new users

Postby escolar » 16 Sep 2019 15:33

Arjen Balfoort wrote:
16 Sep 2019 14:26
I have only these enabled in /etc/lightdm/lightdm.conf:

Code: Select all

[SeatDefaults]
greeter-hide-users=false
allow-user-switching=true
session-wrapper=/etc/lightdm/Xsession
You have the first two also, but you're missing the session-wrapper.
Maybe that helps.
It doesn't work. I have tried your configuration without results

I have tried to remove completely lightdm and reinstall again and I only obtain a list with my name and "Others", so no changes too

EDIT:
I solved it
I added to any user /bin/bash in Login Shell using Kuser (it was empty) and now the list shows all users

Thanks for your help

User avatar
ilu
Posts: 2477
Joined: 09 Oct 2013 12:45

Re: [Solved]Lightdm does not show new users

Postby ilu » 16 Sep 2019 16:33

I'd always recommend to add users with the gui. That way you can hope to get sane defaults. At least on xfce that works. No idea about kuser though.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 7 guests