Can't update

Questions about software.
User avatar
Zero Angel
Posts: 121
Joined: 01 Aug 2014 22:50

Can't update

Postby Zero Angel » 07 Nov 2019 21:51

Hey all, whenever I try to run "sudo apt-get dist-upgrade" after doing update, then I get the following output.

Code: Select all

david@winterbird:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libjs-prototype libjs-scriptaculous linux-headers-4.9.0-4-amd64 linux-headers-4.9.0-4-common linux-headers-4.9.0-5-amd64 linux-headers-4.9.0-5-common linux-image-4.9.0-4-amd64 linux-image-4.9.0-5-amd64
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libclamav9 linux-headers-4.9.0-11-amd64 linux-headers-4.9.0-11-common linux-image-4.9.0-11-amd64
The following packages will be upgraded:
  autopoint base-files clamav clamav-base clamav-freshclam cups cups-bsd cups-client cups-common cups-core-drivers cups-daemon cups-ppdc cups-server-common darktable e2fslibs e2fsprogs exim4-base exim4-config exim4-daemon-light
  faad fig2dev file file-roller firefox-esr firefox-solydxk-adjustments fonts-opensymbol fuse2fs gettext gettext-base ghostscript ghostscript-x google-chrome-stable grub-common grub-efi-amd64-bin grub-efi-ia32-bin grub-pc
  grub-pc-bin grub2-common icu-devtools libarchive13 libasprintf-dev libasprintf0v5 libcaca0 libcomerr2 libcomerr2:i386 libcups2 libcups2:i386 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libebml4v5 libexpat1 libexpat1:i386
  libexpat1-dev libfaad2 libfribidi0 libgd3 libgd3:i386 libgettextpo-dev libgettextpo0 libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libglib2.0-data libgs9 libgs9-common libicu-dev libicu57 libicu57:i386 libkf5config-bin
  libkf5config-data libkf5configcore5 libkf5configgui5 libldap-2.4-2 libldap-2.4-2:i386 libldap-common libmagic-mgc libmagic1 libmariadbclient18 libnghttp2-14 libpam-systemd libpq5 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde
  libreoffice-librelogo libreoffice-math libreoffice-nlpsolver libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-breeze libreoffice-style-galaxy libreoffice-wiki-publisher libreoffice-writer libsdl-image1.2 libss2 libssl1.0.2 libssl1.1
  libssl1.1:i386 libsvn-perl libsvn1 libsystemd0 libsystemd0:i386 libudev1 libudev1:i386 libvlc-bin libvlc5 libvlccore9 libxslt1-dev libxslt1.1 libxslt1.1:i386 lightning linux-compiler-gcc-6-x86 linux-headers-amd64
  linux-image-amd64 linux-kbuild-4.9 linux-libc-dev mariadb-common mariadb-server-core-10.1 minissdpd openjdk-8-jre openjdk-8-jre-headless openssh-client openssh-server openssh-sftp-server openssl python-subversion python3-uno
  solydxk-system solydxk-welcome spotify-client subversion subversion-tools sudo systemd systemd-sysv teamviewer thunderbird tzdata udev uno-libs3 unzip ure usb-creator usbutils vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base
  vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization xsltproc
175 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 104 MB/536 MB of archives.
After this operation, 262 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  darktable
Install these packages without verification? [y/N] y
Err:1 http://repository.spotify.com stable/non-free amd64 spotify-client amd64 1:1.0.80.480.g51b03ac3-13
  404  Not Found [IP: 99.86.134.164 80]
Ign:2 https://repository.solydxk.nl solydxk-9/main amd64 firefox-solydxk-adjustments all 2018.05.31
Ign:3 https://repository.solydxk.nl solydxk-9/main amd64 solydxk-system all 3.0.7b1
Ign:4 https://repository.solydxk.nl solydxk-9/main amd64 solydxk-welcome all 1.5.9
Ign:5 https://repository.solydxk.nl solydxk-9/main amd64 usb-creator all 0.4.9
Err:2 https://repository.solydxk.nl solydxk-9/main i386 firefox-solydxk-adjustments all 2018.05.31
  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
Err:3 https://repository.solydxk.nl solydxk-9/main i386 solydxk-system all 3.0.7b1
  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
Err:4 https://repository.solydxk.nl solydxk-9/main i386 solydxk-welcome all 1.5.9
  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
Err:5 https://repository.solydxk.nl solydxk-9/main i386 usb-creator all 0.4.9
  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
E: Failed to fetch https://repository.solydxk.nl/pool/main/f/firefox-solydxk-adjustments/firefox-solydxk-adjustments_2018.05.31_all.deb  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
E: Failed to fetch https://repository.solydxk.nl/pool/main/s/solydxk-system/solydxk-system_3.0.7b1_all.deb  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
E: Failed to fetch https://repository.solydxk.nl/pool/main/s/solydxk-welcome/solydxk-welcome_1.5.9_all.deb  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
E: Failed to fetch https://repository.solydxk.nl/pool/main/u/usb-creator/usb-creator_0.4.9_all.deb  SSL: certificate subject name (solydxk.nl) does not match target host name 'repository.solydxk.nl'
E: Failed to fetch http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.80.480.g51b03ac3-13_amd64.deb  404  Not Found [IP: 99.86.134.164 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Trying to run sudo apt-get update again doesn't fix it. Is there a way for me to fix things so that I can upgrade my system? It's a couple of years since I installed SolydK and i've only been updating every few months so it's natural that things would start to fall apart.

Any advice?

User avatar
Zero Angel
Posts: 121
Joined: 01 Aug 2014 22:50

Re: Can't update

Postby Zero Angel » 07 Nov 2019 21:53

Code: Select all

david@winterbird:~$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb https://repository.solydxk.nl solydxk-9 main upstream import
           deb http://deb.debian.org/debian stretch main contrib non-free
           deb http://security.debian.org stretch/updates main contrib non-free
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
           deb http://deb.debian.org/debian stretch-updates main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/graphics:darktable.list
           deb http://download.opensuse.org/repositories/graphics:/darktable/Debian_9.0/ /
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
           Active apt sources in file: /etc/apt/sources.list.d/teamviewer.list
           deb http://linux.teamviewer.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/virtualbox.list
           deb http://download.virtualbox.org/virtualbox/debian stretch contrib

nuts2u
Posts: 84
Joined: 03 Nov 2013 21:07

Re: Can't update

Postby nuts2u » 08 Nov 2019 00:43

Right off the bat...get rid of this line:
deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main

DELETE and don't look back

Never...ever use ubuntu ppa's in a Debian based system. You are just looking to hose your system for good.

Looks like this link is no good either:

deb http://repository.spotify.com stable non-free

Rem it out of your sources file and try the update again.

As far as the certificate security errors from the SolydXK lines...that is one for the SolydXK support team to help you with


Liberalism is the art of standing on your head,
then telling everyone around you that they're upside-down.

kurotsugi
Posts: 2234
Joined: 09 Jan 2014 00:17

Re: Can't update

Postby kurotsugi » 08 Nov 2019 00:56

you can try to delete 's' from https on the repo list. if that didn't work, disable it until the issue got resolved

User avatar
Arjen Balfoort
Site Admin
Posts: 9309
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Can't update

Postby Arjen Balfoort » 08 Nov 2019 11:49

In /etc/sources.list you need to replace "repository.solydxk.nl" with "repository.solydxk.com"
Then run

Code: Select all

apt update
apt dist-upgrade


SolydXK needs you!
Development | Testing | Translations

User avatar
Zero Angel
Posts: 121
Joined: 01 Aug 2014 22:50

Re: Can't update

Postby Zero Angel » 08 Nov 2019 19:29

Changing the domain names helped. I also nuked the old spotify repo and installed a newer one into sources.list. Update went smoothly!


Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests