Package updater question

Questions about software.
User avatar
troypulk
Posts: 184
Joined: 20 Jul 2014 22:43
Location: Washington State, USA

Package updater question

Postby troypulk » 23 May 2020 20:03

I'm on my laptop:
Linux solydx 5.5.0-2-amd64 #1 SMP Debian 5.5.17-1 (2020-04-15) x86_64 GNU/Linux

I'm using Apt to update and I haven't updated the laptop in a while so around 300 updates installed.

After this I ran sudo apt upgrade again and the following was posted:

The following packages have been kept back:
libhd21 libhttp-message-perl libjs-jquery linux-headers-amd64 linux-image-amd64 solydx-system-adjustments-11

So to see if the Package updater would explain why I went there and it has these 6 plus 9 more saying they are ready to install with no warnings.

So if there is a difference between the two which one takes precedence?

Thanks

User avatar
Arjen Balfoort
Site Admin
Posts: 9425
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Package updater question

Postby Arjen Balfoort » 24 May 2020 07:27

So, you are using the Enthusiast's Edition (Debian testing).

In that case you need to run:

Code: Select all

apt update
apt dist-upgrade
dist-upgrade will pull in any new packages that already installed packages now depend upon.

After that for good measure:

Code: Select all

apt -f install


SolydXK needs you!
Development | Testing | Translations

User avatar
troypulk
Posts: 184
Joined: 20 Jul 2014 22:43
Location: Washington State, USA

Re: Package updater question

Postby troypulk » 24 May 2020 15:31

Thanks for the help.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest